Les sauvegardes de vApp DPE échouent avec l’erreur « vmwappimage Error <19591>: httpPost: http_code: 500 sending to url 'https://localhost:8080/vcp-ba-vappplugin-ws/vapp' » en raison de problèmes d’équilibreur de charge
Summary: Les sauvegardes de vApp DPE échouent avec l’erreur « vmwappimage Error<19591>: httpPost: http_code: 500 sending to url 'https://localhost:8080/vcp-ba-vappplugin-ws/vapp' » en raison de problèmes d’équilibreur de charge. Les équilibreurs de charge tels que celui de CloudFlare sont connus pour provoquer une erreur de délai d’expiration HTTP 524 Origin qui entraîne l’échec des sauvegardes. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Le journal de sauvegarde peut afficher le message d’erreur suivant :
2021-02-08 10:02:50 vmwappimage Info <19594>: httpPost: url https://localhost:8080/vcp-ba-vappplugin-ws/vapp 2021-02-08 10:03:22 vmwappimage Error <19591>: httpPost: http_code: 500 sending to url 'https://localhost:8080/vcp-ba-vappplugin-ws/vapp' 2021-02-08 10:03:22 vmwappimage Info <9772>: Starting graceful (staged) termination, Prep-for-backup message to ADS failed (wrap-up stage) 2021-02-08 10:03:22 vmwappimage Error <0000>: Prep-for-backup message to ADS failed 2021-02-08 10:03:22 vmwappimage Info <19594>: httpPost: url https://localhost:8080/vcp-ba-vappplugin-ws/vapp 2021-02-08 10:03:45 vmwappimage Error <19591>: httpPost: http_code: 500 sending to url 'https://localhost:8080/vcp-ba-vappplugin-ws/vapp' 2021-02-08 10:03:45 vmwappimage Error <17707>: Post backup-complete message to ADS failed. 2021-02-08 10:03:45 vmwappimage Info <16038>: Final summary, cancelled/aborted 0, snapview 0, exitcode 157: miscellaneous error Le fichier vcdsdk.log sur le VPA à l’emplacement « /var/log/vcp/srv/vcdsdk.log » affiche l’erreur suivante :
> 2021-02-12 11:58:37,368 [LISTENER AMQP 9] INFO (RestUtil.java:329) - Response - <html>> <head><title>524 OriginTime-out</title></head>> <body bgcolor="white"> > <center><h1>524 Délai d’expiration de l’origine</h1></center> > <hr><center>cloudflare-nginx</center> > </body>> </html> Remarque : vous devrez peut-être ajouter le débogage de l’API Cloud VCDSDK pour confirmer l’erreur ci-dessus :
Étapes pour activer le débogage de l’API Cloud :
1. Connectez-vous au nœud principal VCP 2. Modifiez les fichiers /etc/vcp/srv/vcpsrv-log4j2.xml 3. Contenu d’origine : <Logger name="com.vmware" level="info" additivity="true" /> Remplacez cette ligne par : <Logger name="com.vmware" level="debug" additivity="true" /> 4. Veuillez redémarrer le service bg et srv, vcp-cli bg update -p <MASTER-PASSWORD> <BG-INSTANCE-NAME> vcp-cli srv update -p <MASTER-PASSWORD> <SRV-CELL-INSTANCE-NAME>
L’exécution de la commande nslookup sur un FQDN vCloud Director à partir de VPA affiche plusieurs adresses IP.
Le client confirme qu’un équilibreur de charge est configuré.
Cause
Les passerelles de sauvegarde qui tentent de se connecter à vCloud Director atteignent l’équilibreur de charge CloudFlare. La demande d’API échoue sur l’équilibreur de charge CloudFlare à l’origine du problème.
Le code de retour que l’équilibreur de charge CloudFlare fournit est le suivant :
2021-02-12 11:58:37,368 [AMQP listener 9] INFO (RestUtil.java:329) - Response - <html> > <head><title>524 Origin Time-out</title></head> > <body bgcolor="white"> > <center><h1>524 Origin Time-out</h1></center> > <hr><center>cloudflare-nginx</center> > </body> > </html>
Le code de retour que l’équilibreur de charge CloudFlare fournit est le suivant :
2021-02-12 11:58:37,368 [AMQP listener 9] INFO (RestUtil.java:329) - Response - <html> > <head><title>524 Origin Time-out</title></head> > <body bgcolor="white"> > <center><h1>524 Origin Time-out</h1></center> > <hr><center>cloudflare-nginx</center> > </body> > </html>
Resolution
1. Vérifiez auprès du client qu’il dispose bien d’un équilibreur de charge configuré entre les composants VPA tels que les passerelles de sauvegarde, etc., et vCloud Director.
2. Ajoutez des entrées de fichier hôte local pour toutes les machines virtuelles de conteneur docker pour forcer manuellement les composants du boîtier DPE à se connecter à vCloud Director à l’aide d’une adresse IP privée contournant l’équilibreur de charge.
3. Sur les versions DPE antérieures à la version 19.4, les entrées de fichier hôte peuvent être créées sur des machines virtuelles DPE individuelles telles que la machine virtuelle SRV-Cell, la machine virtuelle Backup Gateway, etc.
4. Sur les versions 19.4 et versions antérieures du boîtier DPE, des modifications doivent être apportées à chaque conteneur docker.
2. Ajoutez des entrées de fichier hôte local pour toutes les machines virtuelles de conteneur docker pour forcer manuellement les composants du boîtier DPE à se connecter à vCloud Director à l’aide d’une adresse IP privée contournant l’équilibreur de charge.
3. Sur les versions DPE antérieures à la version 19.4, les entrées de fichier hôte peuvent être créées sur des machines virtuelles DPE individuelles telles que la machine virtuelle SRV-Cell, la machine virtuelle Backup Gateway, etc.
4. Sur les versions 19.4 et versions antérieures du boîtier DPE, des modifications doivent être apportées à chaque conteneur docker.
- Ouvrez SSH sur la machine virtuelle VPA
- Exécutez la commande suivante pour extraire la liste des conteneurs docker : docker ps
- Exécutez la commande suivante pour saisir le conteneur docker : docker exec -it <first 2 digits of containerid> /bin/bash
- Exécutez la commande suivante pour mettre à jour les enregistrements de fichier des hôtes locaux :echo "IP_ADDRESS FQDN SHORTNAME" >> /etc/hosts
Remarque importante : le redémarrage des services VPA (Cell-SRV/BG) détruit le docker et le recrée. Par conséquent, les modifications apportées aux fichiers hôtes doivent être à nouveau mises à jour.
Affected Products
Avamar, vCloud Director Data Protection ExtensionProducts
PowerProtect Data Protection ApplianceArticle Properties
Article Number: 000183920
Article Type: Solution
Last Modified: 01 Aug 2021
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.