Unisphere: "Se produjo un error al intentar recuperar el certificado para ESXi: abc"

Summary: Se observa el siguiente error cuando se registra ESXi vCenter Server xyz.abc.local en Unisphere para PowerMax 9.1.0.18: "Se produjo un error al intentar recuperar el certificado para ESXi:xyz.abc.local Se está utilizando un certificado firmado por una CA de confianza. Se está utilizando un certificado firmado por una CA de confianza. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Se observa el siguiente error cuando se registra ESXi vCenter Server xyz.abc.local en Unisphere para PowerMax 9.1.0.18: :

"An error occurred while attempting to retrieve the certificate for ESXi:xyz.abc.local Error:com.emc.em.smc.VirtualIntegration.exceptions.VmWareException: Failed to retrieve the issuer certificate for ESXi: xyz.abc.local Please check that the CA certificate exists on the ESXi/vCenter Server."

 

Nota: xyz.abc.local representa el nombre de dominio calificado (FQDN) del servidor ESXi con la dirección IP 11.22.33.44. Este es un ejemplo.

Captura de pantalla que muestra el error

 

  • Se está utilizando un certificado firmado por una CA de confianza.
  • El FQDN y la dirección IP de vCenter Server de ESXi responden correctamente a los pings.
  • Nslookup resuelve el FQDN del servidor en la dirección IP correcta.
  • El uso de la IP en lugar del FQDN produce el mismo error.
  • Una conexión OpenSSL al FQDN mediante el puerto 443 se realizó correctamente.
  • Se está utilizando TLSv1.2.
  • La comprobación en vSphere Client muestra que el certificado de CA está presente en vCenter Server de ESXi como un certificado de cadena de tres partes.

En SMAS.log se pueden encontrar los siguientes errores:

WARN  [em.smc.SMC] (default task-48) ManageServerService.getVMwareSystemDetails: Couldn't find a certificate for vCenter/ESXi server details. User has not accepted it
ERROR [em.smc.COMMAND] (default task-48) VirtualServerAndVmCommandProcessor.registerVCenterServer: No Certificate found for vCenter/ESXi Server.
ERROR [em.smc.SMC] (default task-17) com.emc.em.smc.VirtualIntegration.VirtualDeviceService.obtainCertificate(): Exception Creating Certificate Trust Issuer for: xyz.abc.local
ERROR [em.smc.SMC] (default task-17) com.emc.em.smc.VirtualIntegration.VirtualDeviceService.obtainCertificate(): An Error occurred while attempting to retrieve the Certificate for ESXi: xyz.abc.local Error : com.emc.em.smc.VirtualIntegration.exceptions.VmWareException: Failed to retrieve the issuer certificate for ESXi: xyz.abc.local Please Check the CA Certificate exists on the ESXi/vCenter Server 
[em.smc.COMMAND] (default task-17) VirtualServerAndVmCommandProcessor.registerVCenterServer: An Error occurred while attempting to retrieve the Certificate for ESXi: xyz.abc.local Error: com.emc.em.smc.VirtualIntegration.exceptions.VmWareException: Failed to retrieve the issuer certificate for ESXi: xyz.abc.local Please Check the CA Certificate exists on the ESXi/vCenter Server

Cause

El error indica que la parte de VMware de Unisphere no se puede conectar al certificado ESXi. No está relacionado con el certificado de Unisphere.

Resolution

VMware ViClient maneja la cadena de certificados. Unisphere pasa la ubicación del certificado .pem a VMware, por lo que hay un problema en la lógica del certificado en el cual no se admiten más de x (por ejemplo, dos) certificados en la cadena de confianza.

Es posible que los certificados de ESXi no estén configurados correctamente.

También hay una mejora para el manejo de certificados en Unisphere con respecto a la longitud de la cadena de certificados. Se planifica una corrección para el e-Pack de seguridad del tercer trimestre de 2022. Comuníquese con el soporte de Dell para obtener más detalles.

Article Properties
Article Number: 000184093
Article Type: Solution
Last Modified: 07 Aug 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.