XC 13G | iDRAC 2.70.70.70 | Gli aggiornamenti di LCM non riescono e WSMAN si arresta dopo varie query

Summary: Gli aggiornamenti di LCM potrebbero non riuscire su una piattaforma XC 13G con firmware iDRAC 2.70.70.70 installato.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Gli aggiornamenti di LCM potrebbero non riuscire su una piattaforma XC 13G con firmware iDRAC 2.70.70.70 installato.  WSMAN si interromperà anche dopo più query.

Altri sintomi sono:

  • pta_debug.log mostrerà "wsman: TimedOut" che indica che iDRAC non ha risposto a wsman.
  • I registri di traccia di iDRAC mostreranno le risorse non disponibili
    • Per raccogliere i registri di traccia iDRAC, è possibile raccogliere tramite
      • Comandi racadm locali o remoti utilizzando 'racadm gettracelog'; o
      • Accedere all'interfaccia utente web di iDRAC8 accedendo a Overview>Server >Troubleshooting >Diagnostics e inserendo "gettracelog" nella casella di testo del comando.
    • Lo stato di risorse non disponibili quando iDRAC si trova in questa condizione problematica sarà simile al seguente:
Registrazione: 61 
Data/ora: 10 febbraio 13:25:33 
Fonte: avct_wsman 
Descrizione: /home/jenkins/jenkins_slave_builds_prod/workspace/idrac-13g-q2fy21-master-release-A-Rev/build-yocto-sh4/tmp/work/sh4-poky-linux/wsmanhandler-1.0+git146+ac7a4ff59f1e5c05877b606a9ec81e1d201572cc-r21.15/source/src/av 
------------------------------------------------------------------------------- 
Registrazione: 62 
Data/ora: 10 febbraio 13:25:35 
Fonte: 
Description: 
------------------------------------------------------------------------------- 
Registrazione: 63 
Data/ora: 10 febbraio 13:25:36 
Fonte: sfcb[32422] 
Descrizione: spGetMsg ricevuto da 18 32526-11 Risorsa temporaneamente non disponibile 
------------------------------------------------------------------------------- 
Registrazione: 64 
Data/ora: 10 febbraio 13:25:36 
Fonte: sfcb[32422] 
Descrizione: rcvMsg riceve da 18 32526-11 Risorsa temporaneamente non disponibile 
------------------------------------------------------------------------------- 
Registrazione: 65 Data/Ora: Feb 10 13:25:36 Origine: sfcb[32422] Descrizione: spRecvReq ha restituito l'errore -1. Messaggio ignorato.
  • L'output curl per il comando "curl -s -k https://192.168.5.1:8086/api/PT/v1/host/agentinfo" sarà corretto e apparirà simile al seguente:
"ptagentversion": "2.2.0-32", 
"uptime": "14099 secondi (3 ore 54 minuti 59 secondi)", 
"ism_version": "3.5.1-1949.el7.x86_64", 
"system_uuid": "4c4c4544-0059-4d10-804e-c7c04f484c32",
"process_id": "17097",
"host_epoch_time": "1611749201.950011 (sec.usecs)",
"modello": "Dell XC730xd-12C",
"nome": "NTNX-SAMPLE-A", 
"mfr": "Dell Inc.",
"dominio": "(nessuno)", 
"codice di matricola": "ABC1234",
"os": "CentOS Linux",
"os_version": "7.8.2003 (Core)",
"rest_endpoints": "https://192.168.5.1:8086",
"api_whitelisting_enabled": "false",
"MarvellLibraryVersion": "5.0.13.1109",
"idrac_pass_thru_ip": "169.254.0.1", 
"idrac_ethernet_ip": "192.168.127.148",
"host_pass_thru_ip": "169.254.0.2",
"stato": {
"idraccache": "Va bene", 
"idracConnection": "Va bene", 
"iSM": "N/D", 
"agente": "Va bene"} 
  • L'inventario LCM ha esito negativo e il cliente non può aggiornare il firmware sui nodi.
  • Il ping dell'indirizzo IP dell'iDRAC avrebbe comunque esito positivo.

Cause

Il team Dell EMC Engineering ha identificato un problema che causava un rallentamento delle prestazioni dell'interfaccia utente dell'iDRAC durante l'esecuzione di più sessioni WSMan.

Resolution

Dell EMC Engineering ha risolto il problema nel firmware iDRAC8 2.75.100.75.
  • Il firmware iDRAC8 2.75.100.75 è disponibile in LCM 2.4.1 e versioni successive.
  • Il firmware iDRAC8 2.75.100.75 è disponibile anche sul sito del supporto Dell qui.

Se necessario, prima di eseguire l'aggiornamento al firmware iDRAC8 2.75.100.75, è possibile eseguire un soft reset di iDRAC8 per alleviare temporaneamente la lentezza. Seguire la procedura di soft reset specifica per iDRAC8 identificata in Come ripristinare l'iDRAC (Internal Dell Remote Access Controller) su un server PowerEdge?

Affected Products

Dell XC430 Hyper-converged Appliance, Dell XC430 Xpress Hyper-converged Appliance, Dell XC630 Hyper-converged Appliance, Dell XC6320 Hyper-converged Appliance, Dell XC730 Hyper-converged Appliance, Dell XC730XD Hyper-converged Appliance
Article Properties
Article Number: 000184286
Article Type: Solution
Last Modified: 18 Mar 2021
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.