PowerStore: Неможливо налаштувати поштові сервери ESMTP

Summary: Спроба налаштувати ESMTP-пошту не вдається через повідомлення про помилку: "Провалив тест конфігурації SMTP, Причина: Не вдалося підключитися до хоста, порт: smtp.office356.com, 587; тайм-аут 25000" (коригується користувачем) ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Під час відправлення тестового листа або SMTP-повідомлення це може не спрацювати, якщо виконані такі умови:

  • Розширення STARTTLS або SMTP-AUTH увімкнені на SMTP-сервері
  • Версія PowerStoreOS — 4.1 або раніша

 

Наступна помилка може бути зафіксована в журналах Control Path при налаштуванні пристрою PowerStore для використання ESMTP-сервера (наприклад, Outlook365 або інших хмарних поштових сервісів):

Mar 10 15:19:02 APM01210604693-A control-path[12519]: 2021-03-10 15:19:02.689 [] [ERROR] [com.emc.bedrock.command.CommandServiceVerticle|vert.x-eventloop-thread-3] [1aad1cb7-bc69-4aa1-a209-7947a0c32f68] Received a response to com.emc.cyclone.contexts.networkconfiguration.domain.commands.SmtpTestCommand parent id: , instance id: 0, start time: 2021-03-10T15:19:02.313Z, Command initialized by REST request d1874425-9930-4015-8d2e-58878b0c55c0
Failed SMTP config test, Reason: Couldn't connect to host, port: smtp.office356.com, 587; timeout 25000

Cause

Версія PowerStoreOS 4.1 і раніше не підтримують специфічні розширення SMTP, які потрібні для серверів ESMTP.

 

 

Resolution

PowerStoreOS 4.1 або раніше: Вимкніть налаштування розширень STARTTLS та SMTP-AUTH на SMTP-сервері. (Використовуйте базовий SMTP-сервер)
 
PowerStoreOS 4.2 або вище: Перевірте налаштування автентифікації сервера SMTP як у PowerStore, так і в SMTP-серверному додатку. Крім того, перевірте налаштування ретрансляції електронної пошти, а також будь-які налаштування, пов'язані з середовищем, мережею чи міжмережевим екраном.

Affected Products

PowerStore
Article Properties
Article Number: 000184400
Article Type: Solution
Last Modified: 03 Dec 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.