PowerStore: Přidání dalšího zařízení do stávajícího clusteru se nezdaří
Summary: Přidání nového zařízení do stávajícího clusteru může selhat, pokud se uživatel před tím pokusí přihlásit do nástroje PowerStore Manager nového zařízení.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Přidání zařízení do stávajícího clusteru se nezdaří s chybovými kódy:
V nástroji PowerStore Manager:
- Clustering operation failed, Reason: Platform error: java.lang.Integer cannot be cast to java.lang.Long (0xE0C010010013).
- Clustering operation failed, Reason: java.lang.Integer cannot be cast to java.lang.Long (0xE0C010010013).
- Failed to delete target port group, Reason: java.lang.Integer cannot be cast to java.lang.Long (0xE0C01001000E).
- The system encountered unexpected backend errors. Please contact support. (0xE0101001000C).
V nástroji PowerStore Manager:
Cause
Tento problém je způsoben pokusem o přístup k nástroji PowerStore Manager (uživatelské rozhraní) nového zařízení prostřednictvím servisního portu před přidáním zařízení do clusteru.
K problému dochází, když je časové razítko vytvoření bezpečnostního modulu před časovým razítkem události joinCluster.
- Pokud dojde k pokusu o přihlášení do uživatelského rozhraní nového zařízení, v protokolu se zobrazí řádek s informacemi o tom, že uživateli admin /api/rest/local_user/1 byl odeslán požadavek PATCH.
| Apr 03 03:09:56 xxxxx-A control-path[20956]: 2021-04-03 03:09:56.310 [] [INFO] [com.emc.bedrock.http.HttpVerticle|vert.x-eventloop-thread-0] Request ID: 28fc0ae7-284d-415e-b5b9-974be4780301. Client IP: xx.xx.xx.xx. Server IP: xx.xx.xx.xx Application type: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/xx Safari/xx Method: PATCH. Processing route: /api/rest/local_user/1. |
- Po přihlášení se uživatelům zobrazí tato obrazovka s žádostí o změnu hesla.
- I když uživatel klikne na tlačítko Cancel a nic nezmění, vytvoří se nový bezpečnostní modul a v protokolech se zobrazí operace související s heslem účtu správce. Tento bezpečnostní modul se započítá jako změna nebo úprava systému, což zabrání přidání zařízení do clusteru.
| Apr 03 03:09:56 xxxxx-A CryptoApi[11782]: Lockbox does not exist, create one. Apr 03 03:10:00 xxxxx-A CryptoApi[11782]: Successfully created and initialized the lockbox. Apr 03 03:10:00 xxxxx-A CryptoApi[11782]: crypto_is_initialized: CryptoApi is already initialized Apr 03 03:10:00 xxxxx-A CryptoApi[11782]: crypto_init: Library is already initialized, skipping initialization process Apr 03 03:10:00 xxxxx-A CryptoApi[11782]: crypto_get_default_key_from_lb: key does not exist Apr 03 03:10:00 xxxxx-A CryptoApi[11782]: crypto_is_initialized: CryptoApi is not initialized, filename is null Apr 03 03:10:00 xxxxx-A CryptoApi[11782]: Successfully set the environment. API version: 1.0.4 |
K problému dochází, když je časové razítko vytvoření bezpečnostního modulu před časovým razítkem události joinCluster.
Resolution
Tento problém je vyřešen ve verzi PowerStoreOS 2.1.0.0 a novějších. Co nejdříve proveďte aktualizaci.
U verzí starších než PowerStoreOS 2.1.0.0:
Aby bylo možné nové zařízení znovu přidat do clusteru, je nutné jej vrátit do čistého továrního stavu:
Pokud zařízení není nalezeno, můžete se do nového zařízení přihlásit pouze přes SSH a zkontrolovat jeho stav (ukázkový příkaz: svc_diag list --icw_hardware). Pokud se vám nepodaří nové zařízení přidat, obraťte se na technickou podporu společnosti Dell EMC nebo autorizovaného servisního zástupce a uveďte ID tohoto článku znalostní databáze.
U verzí starších než PowerStoreOS 2.1.0.0:
Aby bylo možné nové zařízení znovu přidat do clusteru, je nutné jej vrátit do čistého továrního stavu:
- Nové zařízení vrátíte do továrního nastavení opětovnou inicializací. Viz článek znalostní databáze Dell 180964: PowerStore: Opětovná inicializace systému PowerStore do výchozího továrního stavu pomocí příkazu „svc_factory_reset“.
- Před pokusem o přidání nového zařízení do clusteru počkejte alespoň jednu hodinu.
- Nepokoušejte se přihlásit do uživatelského rozhraní nového zařízení.
- Spusťte průvodce přidáním zařízení ze stávajícího clusteru.
Pokud zařízení není nalezeno, můžete se do nového zařízení přihlásit pouze přes SSH a zkontrolovat jeho stav (ukázkový příkaz: svc_diag list --icw_hardware). Pokud se vám nepodaří nové zařízení přidat, obraťte se na technickou podporu společnosti Dell EMC nebo autorizovaného servisního zástupce a uveďte ID tohoto článku znalostní databáze.
Affected Products
PowerStoreArticle Properties
Article Number: 000185006
Article Type: Solution
Last Modified: 15 Sep 2022
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.