PowerStore: Dodanie innego urządzenia do istniejącego klastra kończy się niepowodzeniem

Summary: Dodanie innego urządzenia do istniejącego klastra może się nie powieść, jeśli użytkownik spróbuje zalogować się do programu PowerStore Manager nowego urządzenia przed dodaniem go do klastra. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Dodanie urządzenia do istniejącego klastra może się nie powieść z kodami błędów:
  • Clustering operation failed, Reason: Platform error: java.lang.Integer cannot be cast to java.lang.Long (0xE0C010010013).
  • Clustering operation failed, Reason: java.lang.Integer cannot be cast to java.lang.Long (0xE0C010010013).
  • Failed to delete target port group, Reason: java.lang.Integer cannot be cast to java.lang.Long (0xE0C01001000E).
  • The system encountered unexpected backend errors. Skontaktuj się z pomocą techniczną. (0xE0101001000C).
Uwaga: Ponadto, nawet jeśli nie pojawią się żadne z powyższych kodów, problem mógł nadal występować. Potwierdź to, przeglądając odpowiednie wiersze dziennika wymienione w dalszej części sekcji dotyczącej przyczyn w tej bazy wiedzy, nawet jeśli nie widzisz powyższych kodów w programie PowerStore Manager lub w dziennikach. 

Widoczne w narzędziu PowerStore Manager:
 
image.png
 

Cause

Ten problem jest spowodowany próbą uzyskania dostępu do programu PowerStore Manager (UI) nowego urządzenia za pośrednictwem portu serwisowego przed dodaniem urządzenia do klastra.
  • W przypadku próby zalogowania się do interfejsu użytkownika nowego urządzenia wyświetlony zostanie wiersz dziennika wskazujący, że żądanie POPRAWKI zostało wysłane do /api/rest/local_user/1, czyli administratora.
Apr 03 03:09:56 xxxxx-A control-path[20956]: 2021-04-03 03:09:56.310 [] [INFO] [com.emc.bedrock.http.HttpVerticle|vert.x-eventloop-thread-0]  Request ID: 28fc0ae7-284d-415e-b5b9-974be4780301. Client IP: xx.xx.xx.xx. Server IP: xx.xx.xx.xx Application type: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/xx Safari/xx Method: PATCH. Processing route: /api/rest/local_user/1.
 
  • Jest to pierwszy ekran widoczny dla użytkownika po zalogowaniu, który jest ekranem z prośbą o zmianę hasła.
image.png
  • Nawet jeśli użytkownik kliknie przycisk anulowania i nie zmieni niczego, zostanie utworzona nowa skrytka, a operacje związane z hasłem konta administratora będą widoczne w dziennikach. Będzie to liczone przez skrytkę jako zmiana lub modyfikacja systemu, uniemożliwiająca tym samym dodawanie urządzenia do klastra.
Apr 03 03:09:56 xxxxx-A CryptoApi[11782]: Lockbox does not exist, create one.
Apr 03 03:10:00 xxxxx-A CryptoApi[11782]: Successfully created and initialized the lockbox.
Apr 03 03:10:00 xxxxx-A CryptoApi[11782]: crypto_is_initialized: CryptoApi is already initialized
Apr 03 03:10:00 xxxxx-A CryptoApi[11782]: crypto_init: Library is already initialized, skipping initialization process
Apr 03 03:10:00 xxxxx-A CryptoApi[11782]: crypto_get_default_key_from_lb: key does not exist
Apr 03 03:10:00 xxxxx-A CryptoApi[11782]: crypto_is_initialized: CryptoApi is not initialized, filename is null
Apr 03 03:10:00 xxxxx-A CryptoApi[11782]: Successfully set the environment. API version: 1.0.4
         
Problem występuje, gdy sygnatura czasowa tworzenia skrytki poprzedza sygnaturę czasową zdarzenia joinCluster. 

Resolution

Ten problem został rozwiązany w PowerStoreOS w wersji 2.1.0.0 i nowszych. Zaktualizuj przy pierwszej dogodnej okazji.
 
W przypadku wersji starszych niż PowerStoreOS 2.1.0.0:

Konieczne jest przywrócenie czystego stanu fabrycznego nowego urządzenia, zanim będzie można je ponownie dodać do klastra:
  1. Przywróć nowe urządzenie do stanu fabrycznego poprzez ponowne zainicjowanie. Patrz artykuł bazy wiedzy Dell nr 180964: PowerStore: Ponowna inicjalizacja systemu PowerStore do stanu fabrycznego za pomocą polecenia svc_factory_reset.
  2. Poczekaj co najmniej godzinę przed próbą dodania nowego urządzenia do klastra.
  3. Nie próbuj logować się do interfejsu użytkownika nowego urządzenia.
  4. Uruchom kreator dodawania urządzenia z istniejącego klastra.
Jeśli znaleziono urządzenie, można kontynuować dodawanie urządzenia.

Jeśli nie zostało znalezione, można zalogować się do nowego urządzenia tylko przez SSH w celu sprawdzenia jego stanu (przykład polecenia: svc_diag list --icw_hardware). Jeśli nie można dodać nowego urządzenia, skontaktuj się z działem pomocy technicznej Dell EMC lub autoryzowanym przedstawicielem serwisu i podaj ten identyfikator artykułu z bazy wiedzy.

Affected Products

PowerStore
Article Properties
Article Number: 000185006
Article Type: Solution
Last Modified: 15 Sep 2022
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.