PowerStore. Сбой при добавлении другого устройства в существующий кластер

Summary: Добавление еще одного устройства в существующий кластер может привести к сбою, если пользователь попытается войти в PowerStore Manager нового устройства, прежде чем добавить его в кластер. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

При добавлении устройства в существующий кластер может произойти сбой с кодами ошибок:
  • Clustering operation failed, Reason: Platform error: java.lang.Integer cannot be cast to java.lang.Long (0xE0C010010013).
  • Clustering operation failed, Reason: java.lang.Integer cannot be cast to java.lang.Long (0xE0C010010013).
  • Failed to delete target port group, Reason: java.lang.Integer cannot be cast to java.lang.Long (0xE0C01001000E).
  • The system encountered unexpected backend errors. Please contact support. (0xE0101001000C).
Примечание. Кроме того, проблема могла возникнуть, даже если ни один из вышеперечисленных кодов не отображался. Подтвердите это, просмотрев соответствующие строки журнала, упомянутые далее в разделе «Причина» данной статьи базы знаний, даже если указанные выше коды не отображаются в PowerStore Manager или в журналах. 

Как видно в PowerStore Manager:
 
image.png
 

Cause

Эта проблема вызвана попыткой получения доступа к пользовательскому интерфейсу PowerStore Manager на новом устройстве через служебный порт до добавления устройства в кластер.
  • Если есть попытка входа в пользовательский интерфейс нового устройства, существует и строка в журнале, указывающая на отправку запроса «PATCH» в /api/rest/local_user/1, то есть пользователю, который является администратором.
Apr 03 03:09:56 xxxxx-A control-path[20956]: 2021-04-03 03:09:56.310 [] [INFO] [com.emc.bedrock.http.HttpVerticle|vert.x-eventloop-thread-0]  Request ID: 28fc0ae7-284d-415e-b5b9-974be4780301. Client IP: xx.xx.xx.xx. Server IP: xx.xx.xx.xx Application type: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/xx Safari/xx Method: PATCH. Processing route: /api/rest/local_user/1.
 
  • Это первый экран, который пользователь видит после входа в систему. Он служит для запроса изменения пароля.
image.png
  • Даже если пользователь нажимает кнопку «Cancel» и ничего не меняет, создается новое защищенное хранилище, и в журналах отображаются операции, связанные с паролем учетной записи администратора. Это считается изменением или модификацией системы, что не позволит добавить устройство в кластер.
Apr 03 03:09:56 xxxxx-A CryptoApi[11782]: Lockbox does not exist, create one.
Apr 03 03:10:00 xxxxx-A CryptoApi[11782]: Successfully created and initialized the lockbox.
Apr 03 03:10:00 xxxxx-A CryptoApi[11782]: crypto_is_initialized: CryptoApi is already initialized
Apr 03 03:10:00 xxxxx-A CryptoApi[11782]: crypto_init: Library is already initialized, skipping initialization process
Apr 03 03:10:00 xxxxx-A CryptoApi[11782]: crypto_get_default_key_from_lb: key does not exist
Apr 03 03:10:00 xxxxx-A CryptoApi[11782]: crypto_is_initialized: CryptoApi is not initialized, filename is null
Apr 03 03:10:00 xxxxx-A CryptoApi[11782]: Successfully set the environment. API version: 1.0.4
         
Эта проблема возникает, когда временная метка создания защищенного хранилища находится перед временной меткой события joinCluster. 

Resolution

Эта проблема решена в PowerStoreOS 2.1.0.0 и более поздних версиях. Выполните обновление при первой возможности.
 
Для версий до PowerStoreOS 2.1.0.0.

Новое устройство необходимо вернуть в исходное заводское состояние, прежде чем снова добавлять его в кластер.
  1. Верните устройство в заводское состояние, выполнив повторную инициализацию. Для получения дополнительной информации см. статью 180964 базы знаний Dell: PowerStore. Повторная инициализация системы PowerStore до заводского состояния с помощью команды «svc_factory_reset».
  2. Подождите как минимум один час, прежде чем добавлять новое устройство в кластер.
  3. Не пытайтесь войти в пользовательский интерфейс нового устройства.
  4. Запустите мастер добавления устройства на существующем кластере.
Если устройство обнаружено, его можно добавлять.

Если устройство не обнаружено, то можно выполнить вход в новое устройство только по SSH, чтобы проверить состояние (пример команды: svc_diag list --icw_hardware). Если не удается добавить новое устройство, обратитесь в службу технической поддержки Dell EMC или к уполномоченному представителю службы поддержки и укажите идентификатор этой статьи базы знаний.

Affected Products

PowerStore
Article Properties
Article Number: 000185006
Article Type: Solution
Last Modified: 15 Sep 2022
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.