IDPA: PTAgent Configuration validation failed on component-IDPA Server error seen on IDPA ACM Health Tab
Summary: IDPA: PTAgent Configuration validation failed on component-IDPA Server error seen on IDPA ACM Health Tab
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Symptoms
PTAgent Configuration validation failed on component-IDPA Server error seen on IDPA ACM Health Tab.
UI Error:
* Review the ACM Home Page and click on Refresh button on top right corner.
* Verify the Virtualization Dashboard to confirm if ESXi password shows Out of Sync.
This may cause this issue.
Additionally, Open SSH to ACM as 'root' user and run the following command to verify the error:
grep -i validatePTAgent /usr/local/dataprotection/var/configmgr/server_data/logs/server.log
Example:
2021-04-08 19:57:58,444 ERROR [Timer-3]-snmp.SNMPValidator: validateAndConfigurePtaAgentOnServers --> Failed to configure DellPTAgent
com.emc.vcedpa.common.exception.ApplianceException: Failed to configure DellPTAgent on ESX xxx.xxx.xxx.xxx.
at com.emc.vcedpa.healthmonitor.snmp.PTAgentManager.validateAndConfigurePTAgent(PTAgentManager.java:81)
at com.emc.vcedpa.healthmonitor.snmp.SNMPValidator.validateAndConfigurePtaAgentOnServers(SNMPValidator.java:224)
at com.emc.vcedpa.healthmonitor.snmp.SNMPValidator.run(SNMPValidator.java:109)
at java.util.TimerThread.mainLoop(Timer.java:555)
at java.util.TimerThread.run(Timer.java:505)
2021-04-08 19:57:58,452 INFO [Timer-3]-snmp.PTAgentManager: validatePTAgent --> ESXi:xxx.xxx.xxx.xxx is out of sync. Skipping SSH connection.
2021-04-08 19:57:58,452 ERROR [Timer-3]-snmp.PTAgentManager: validatePTAgent --> Error occured while checking DellPTAgent settings ESXi
com.emc.vcedpa.common.exception.ApplianceException: ESXi xxx.xxx.xxx.xxx root password is out of sync. Click to update the password in Appliance Configuration Manager.
Additionally, user can login to the ESXi Host CLI and run the following command to verify if an unknown device is locking the user:
grep -i error /scratch/log/auth.log
Example:
2021-03-16T20:57:13Z sshd[26160203]: error: PAM: Authentication failure for root from xx.xxx.xx.xx
2021-03-16T20:57:13Z sshd[26160203]: error: Received disconnect from xx.xx.xx.xx port 40065:3: com.jcraft.jsch.JSchException: Auth fail [preauth]
2021-03-16T20:57:13Z sshd[26160214]: error: kex_exchange_identification: Connection closed by remote host
2021-03-16T20:57:15Z sshd[26160218]: error: kex_exchange_identification: Connection closed by remote host
2021-03-16T20:57:16Z sshd[26160215]: error: PAM: User not known to the underlying authentication module for illegal user remotessh from xx.xx.xx.xx
UI Error:
* Review the ACM Home Page and click on Refresh button on top right corner.
* Verify the Virtualization Dashboard to confirm if ESXi password shows Out of Sync.
This may cause this issue.
Additionally, Open SSH to ACM as 'root' user and run the following command to verify the error:
grep -i validatePTAgent /usr/local/dataprotection/var/configmgr/server_data/logs/server.log
Example:
2021-04-08 19:57:58,444 ERROR [Timer-3]-snmp.SNMPValidator: validateAndConfigurePtaAgentOnServers --> Failed to configure DellPTAgent
com.emc.vcedpa.common.exception.ApplianceException: Failed to configure DellPTAgent on ESX xxx.xxx.xxx.xxx.
at com.emc.vcedpa.healthmonitor.snmp.PTAgentManager.validateAndConfigurePTAgent(PTAgentManager.java:81)
at com.emc.vcedpa.healthmonitor.snmp.SNMPValidator.validateAndConfigurePtaAgentOnServers(SNMPValidator.java:224)
at com.emc.vcedpa.healthmonitor.snmp.SNMPValidator.run(SNMPValidator.java:109)
at java.util.TimerThread.mainLoop(Timer.java:555)
at java.util.TimerThread.run(Timer.java:505)
2021-04-08 19:57:58,452 INFO [Timer-3]-snmp.PTAgentManager: validatePTAgent --> ESXi:xxx.xxx.xxx.xxx is out of sync. Skipping SSH connection.
2021-04-08 19:57:58,452 ERROR [Timer-3]-snmp.PTAgentManager: validatePTAgent --> Error occured while checking DellPTAgent settings ESXi
com.emc.vcedpa.common.exception.ApplianceException: ESXi xxx.xxx.xxx.xxx root password is out of sync. Click to update the password in Appliance Configuration Manager.
Additionally, user can login to the ESXi Host CLI and run the following command to verify if an unknown device is locking the user:
grep -i error /scratch/log/auth.log
Example:
2021-03-16T20:57:13Z sshd[26160203]: error: PAM: Authentication failure for root from xx.xxx.xx.xx
2021-03-16T20:57:13Z sshd[26160203]: error: Received disconnect from xx.xx.xx.xx port 40065:3: com.jcraft.jsch.JSchException: Auth fail [preauth]
2021-03-16T20:57:13Z sshd[26160214]: error: kex_exchange_identification: Connection closed by remote host
2021-03-16T20:57:15Z sshd[26160218]: error: kex_exchange_identification: Connection closed by remote host
2021-03-16T20:57:16Z sshd[26160215]: error: PAM: User not known to the underlying authentication module for illegal user remotessh from xx.xx.xx.xx
Cause
- Security scanners causing IDPA ESXi root user to get locked. If ESXi root user is locked, it will throw Password out of sync message on ACM.
- Another scenario which would cause this issue would be ACM having password sync issues with ESXi.
Resolution
1. Click on Password out of sync message on ACM UI - Virtualization Dashboard and update the correct password.
2. SSH to ACM CLI using 'root' user and restart the webapp service:
# service dataprotection_webapp restart
3. Clear the browser cache.
4. Re-login to the UI and verify issue is fixed.
5. Whitelist ESXi and other IDPA Components from security scanners to avoid ESXi lockouts.
2. SSH to ACM CLI using 'root' user and restart the webapp service:
# service dataprotection_webapp restart
3. Clear the browser cache.
4. Re-login to the UI and verify issue is fixed.
5. Whitelist ESXi and other IDPA Components from security scanners to avoid ESXi lockouts.
Affected Products
Integrated Data Protection Appliance FamilyProducts
PowerProtect Data Protection SoftwareArticle Properties
Article Number: 000185105
Article Type: Solution
Last Modified: 05 Aug 2021
Version: 3
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