Сбой generate-java-truststore.sh, если язык не установлен на английский или французский

Summary: Сценарии или задачи не будут выполнены успешно, что приведет к ошибкам интерфейса командной строки, невозможно найти базовую локализацию

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

SMRFE:# /opt/APG/bin/generate-java-truststore.sh 
Exception in thread "main" java.lang.ExceptionInInitializerError
       at com.watch4net.apg.java.cli.CliProgressionListener.(CliProgressionListener.java:26)
       at com.watch4net.apg.java.cli.GenerateTruststoreCli.main(GenerateTruststoreCli.java:62)
Caused by: java.util.MissingResourceException: Can't find bundle for base name com.watch4net.apg.java.locale.resources, locale es_ES
       at java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:1581)
       at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1396)
       at java.util.ResourceBundle.getBundle(ResourceBundle.java:782)
       at com.watch4net.apg.java.locale.Resources.(Resources.java:18)
       ... 2 more

Cause

Если для языка интерфейса командной строки или локализации установлен какой-либо язык, кроме английского или французского, вы увидите ошибку. 
 
Программное обеспечение для мониторинга и составления отчетов доступно на следующих языках:
• Английский
• Французский


Resolution

Измените локализацию на поддерживаемый язык

В приведенной выше ошибке отображается язык |language is set to es_ES


Просмотрите текущие настройки:
# locale

Просмотрите доступные языки:
# locale -a 
 
Измените язык на английский
# LANG=en_US
# locale
 
Запустите сценарий:
# /opt/APG/bin/generate-java-truststore.sh

Affected Products

Storage Monitoring and Reporting, SRM, VNX Family Monitoring and Reporting
Article Properties
Article Number: 000185536
Article Type: Solution
Last Modified: 15 Dec 2022
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.