NetWorker: Laufzeit-Rendering (daemon.log) funktioniert nach dem NetWorker-Upgrade nicht mehr

Summary: Das Laufzeit-Rendering (daemon.log) funktioniert nach dem Upgrade auf NW 19.3.0.4 nicht mehr

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

– Das Laufzeit-Rendering funktioniert nach NW-Update nicht mehr.
– Das Daemon-Protokoll wird nicht mehr aktualisiert.

Cause

– NSR LOG verfügt über eine hohe Anzahl verdächtiger Einträge unter NSR LOG, z. B.:

# nsradmin -p nsrexec
> p type:nsr log
...
..

type:nsr log
                        type: NSR log;
               administrator: root, "user=nsrnmc,host=nw-server1.vlab.local",
                              "user=root,host=nw-server1.vlab.local";
                       owner: nsrpolicy;
             maximum size MB: 2;
            maximum versions: 10;
        runtime rendered log:;
    runtime rollover by size: Disabled;
    runtime rollover by time:;
                        name: Group_name.raw;
                    log path: /nsr/logs/migration/Group_name.raw;
...
..
.
OR
...
..
.
 type: NSR log;
               administrator: root, "user=nsrnmc,host=nw-server1.vlab.local",
                              "user=root,host=nw-server1.vlab.local";
                       owner: Adhoc job log;
             maximum size MB: 2;
            maximum versions: 10;
        runtime rendered log: ;
    runtime rollover by size: Disabled;
    runtime rollover by time: ;
                        name: adhoc-job-hMfdQc;
                    log path: /nsr/logs/adhoc/adhoc-job-hMfdQc;
...
.
                        type: NSR log;
               administrator: root, "user=nsrnmc,host=nw-server1.vlab.local",
                              "user=root,host=nw-server1.vlab.local";
                       owner: Adhoc job log;
             maximum size MB: 2;
            maximum versions: 10;
        runtime rendered log: ;
    runtime rollover by size: Disabled;
    runtime rollover by time: ;
                        name: adhoc-job-9Q4xBr;
                    log path: /nsr/tmp/adhoc/adhoc-job-9Q4xBr;
...
..
.



– Stellen Sie sicher, dass nur „obligatorische“ Einträge unter NSR LOG vorhanden sind, z. B. gstd, nsrim, nsrcpd, daemon.

e.g.:
# nsradmin -p nsrexec
nsradmin> show name
nsradmin> p type:nsr log
                       owner: nsrim;
                        name: nsrim.raw;

                       owner: NetWorker;
                        name: daemon.raw;

                       owner: NetWorker;
                        name: nsrcpd.raw;

                       owner: nsrdsa_recover;
                        name: nsrdsa_recover.raw;

                       owner: NMC Log Fuile;
                        name: gstd.raw;

                       owner: nsrdsa_save;
                        name: nsrdsa_save.raw;
nsradmin>

Resolution

– Erstellen Sie eine Kopie von nsrladb.
– Suchen Sie nach verdächtigen Einträgen und entfernen Sie sie.
– Einträge können z. B. „Adhoc“ oder „Migration“ lauten (andere Einträge sind auch möglich):

– Löschen Sie diese Einträge mithilfe von nsradmin (interaktiver Modus) oder über die Eingabedatei,

z. B.
# vi del_adhoc
delete owner:Adhoc job log;

# nsradmin -p nsrexec -i del_adhoc


– Stellen Sie sicher, dass nur „obligatorische“ Einträge unter NSR LOG vorhanden sind (z. B.: gstd, nsrim, nsrcpd, daemon),

z. B.:
# nsradmin -p nsrexec
nsradmin> show name
nsradmin> p type:nsr log
                       owner: nsrim;
                        name: nsrim.raw;

                       owner: NetWorker;
                        name: daemon.raw;

                       owner: NetWorker;
                        name: nsrcpd.raw;

                       owner: nsrdsa_recover;
                        name: nsrdsa_recover.raw;

                       owner: NMC Log Fuile;
                        name: gstd.raw;

                       owner: nsrdsa_save;
                        name: nsrdsa_save.raw;
nsradmin>


– Schalten Sie den NW-Server aus.
– Löschen Sie den Inhalt unter /nsr/tmp/.

– Starten Sie den NW-Server. Das Laufzeit-Rendering-Protokoll funktioniert jetzt ordnungsgemäß.

Affected Products

NetWorker
Article Properties
Article Number: 000186465
Article Type: Solution
Last Modified: 05 Aug 2021
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.