NetWorker: käytönaikainen jäsennys (daemon.log) ei enää toimi NetWorker-päivityksen jälkeen

Summary: Käytönaikainen jäsennys (daemon.log) ei enää toimi, kun NW on päivitetty versioon 19.3.0.4

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

- Käytönaikainen jäsennys ei enää toimi NW-päivityksen jälkeen
- Daemon-lokia ei enää päivitetä

Cause

- NSR-lokissa on runsaasti epäilyttäviä merkintöjä, kuten :

# nsradmin -p nsrexec
> p type:nsr log
...
..

type:nsr log
                        type: NSR log;
               administrator: root, "user=nsrnmc,host=nw-server1.vlab.local",
                              "user=root,host=nw-server1.vlab.local";
                       owner: nsrpolicy;
             maximum size MB: 2;
            maximum versions: 10;
        runtime rendered log:;
    runtime rollover by size: Disabled;
    runtime rollover by time:;
                        name: Group_name.raw;
                    log path: /nsr/logs/migration/Group_name.raw;
...
..
.
OR
...
..
.
 type: NSR log;
               administrator: root, "user=nsrnmc,host=nw-server1.vlab.local",
                              "user=root,host=nw-server1.vlab.local";
                       owner: Adhoc job log;
             maximum size MB: 2;
            maximum versions: 10;
        runtime rendered log: ;
    runtime rollover by size: Disabled;
    runtime rollover by time: ;
                        name: adhoc-job-hMfdQc;
                    log path: /nsr/logs/adhoc/adhoc-job-hMfdQc;
...
.
                        type: NSR log;
               administrator: root, "user=nsrnmc,host=nw-server1.vlab.local",
                              "user=root,host=nw-server1.vlab.local";
                       owner: Adhoc job log;
             maximum size MB: 2;
            maximum versions: 10;
        runtime rendered log: ;
    runtime rollover by size: Disabled;
    runtime rollover by time: ;
                        name: adhoc-job-9Q4xBr;
                    log path: /nsr/tmp/adhoc/adhoc-job-9Q4xBr;
...
..
.



- make sure only "mandatory" entries are under NSR LOG, like gstd, nsrim, nsrcpd, daemon

e.g.:
# nsradmin -p nsrexec
nsradmin> show name
nsradmin> p type:nsr log
                       owner: nsrim;
                        name: nsrim.raw;

                       owner: NetWorker;
                        name: daemon.raw;

                       owner: NetWorker;
                        name: nsrcpd.raw;

                       owner: nsrdsa_recover;
                        name: nsrdsa_recover.raw;

                       owner: NMC Log Fuile;
                        name: gstd.raw;

                       owner: nsrdsa_save;
                        name: nsrdsa_save.raw;
nsradmin>

Resolution

- Tee kopio kohteesta nsrladb
- Hae epäilyttävät merkinnät ja poista ne
- Merkintöjä voivat olla esimerkiksi Adhoc tai migration (mutta myös muut ovat mahdollisia):

- Poista kyseiset merkinnät nsradminin avulla (vuorovaikutteisessa tilassa) tai syöttötiedoston kautta

esim.
# vi del_adhoc
delete owner:Adhoc job log;

# nsradmin -p nsrexec -i del_adhoc
 

- Varmista, että NSR-lokissa on vain mandatory-merkintöjä (esim.: gstd, nsrim, nsrcpd, daemon)

e.g.:
# nsradmin -p nsrexec
nsradmin> show name
nsradmin> p type:nsr log
                       owner: nsrim;
                        name: nsrim.raw;

                       owner: NetWorker;
                        name: daemon.raw;

                       owner: NetWorker;
                        name: nsrcpd.raw;

                       owner: nsrdsa_recover;
                        name: nsrdsa_recover.raw;

                       owner: NMC Log Fuile;
                        name: gstd.raw;

                       owner: nsrdsa_save;
                        name: nsrdsa_save.raw;
nsradmin>


- shutdown NW Server
- delete content under /nsr/tmp/

- start NW Server, runtime rendered log is now working

Affected Products

NetWorker
Article Properties
Article Number: 000186465
Article Type: Solution
Last Modified: 05 Aug 2021
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.