NetWorker:NetWorkerのアップグレード後にランタイム レンダリング(daemon.log)が機能しなくなる

Summary: NW 19.3.0.4へのアップグレード後にランタイム レンダリング(daemon.log)が機能しなくなります。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

- NWのアップデート後にランタイム レンダリングが機能しなくなる
- デーモン ログが更新されなくなる

Cause

- NSRログに、次のような大量の疑わしいエントリーがあります。

# nsradmin -p nsrexec
> p type:nsr log
...
..

type:nsr log
                        type: NSR log;
               administrator: root, "user=nsrnmc,host=nw-server1.vlab.local",
                              "user=root,host=nw-server1.vlab.local";
                       owner: nsrpolicy;
             maximum size MB: 2;
            maximum versions: 10;
        runtime rendered log:;
    runtime rollover by size: Disabled;
    runtime rollover by time:;
                        name: Group_name.raw;
                    log path: /nsr/logs/migration/Group_name.raw;
...
..
.
または
...
..
.
 type: NSR log;
               administrator: root, "user=nsrnmc,host=nw-server1.vlab.local",
                              "user=root,host=nw-server1.vlab.local";
                       owner: Adhoc job log;
             maximum size MB: 2;
            maximum versions: 10;
        runtime rendered log: ;
    runtime rollover by size: Disabled;
    runtime rollover by time: ;
                        name: adhoc-job-hMfdQc;
                    log path: /nsr/logs/adhoc/adhoc-job-hMfdQc;
...
.
                        タイプ: NSR log;
               administrator: root, "user=nsrnmc,host=nw-server1.vlab.local",
                              "user=root,host=nw-server1.vlab.local";
                       owner: Adhoc job log;
             maximum size MB: 2;
            maximum versions: 10;
        runtime rendered log: ;
    runtime rollover by size: Disabled;
    runtime rollover by time: ;
                        name: adhoc-job-9Q4xBr;
                    log path: /nsr/tmp/adhoc/adhoc-job-9Q4xBr;
...
..
.



- NSRログには、gstd、nsrim、nsrcpd、daemonなどの「必須」エントリーのみがあることを確認します。

例:
# nsradmin -p nsrexec
nsradmin> show name
nsradmin> p type:nsr log
                       owner: nsrim;
                        name: nsrim.raw;

                       owner: NetWorker;
                        name: daemon.raw;

                       owner: NetWorker;
                        name: nsrcpd.raw;

                       owner: nsrdsa_recover;
                        name: nsrdsa_recover.raw;

                       owner: NMC Log Fuile;
                        name: gstd.raw;

                       owner: nsrdsa_save;
                        name: nsrdsa_save.raw;
nsradmin>

Resolution

- nsrladbのコピーを作成します。
- 疑わしいエントリーを探して削除します。
- エントリーは「adhoc」または「migration」にできます(ただし、その他のエントリーも可能です):

- nsradmin(インタラクティブ モード)を使用するか、入力ファイルからそれらのエントリーを削除します。

例:
# vi del_adhoc
delete owner:Adhoc job log;

# nsradmin -p nsrexec -i del_adhoc
 

- NSRログには、gstd、nsrim、nsrcpd、daemonなどの「必須」エントリーのみがあることを確認します。

例:
# nsradmin -p nsrexec
nsradmin> show name
nsradmin> p type:nsr log
                       owner: nsrim;
                        name: nsrim.raw;

                       owner: NetWorker;
                        name: daemon.raw;

                       owner: NetWorker;
                        name: nsrcpd.raw;

                       owner: nsrdsa_recover;
                        name: nsrdsa_recover.raw;

                       owner: NMC Log Fuile;
                        name: gstd.raw;

                       owner: nsrdsa_save;
                        name: nsrdsa_save.raw;
nsradmin>


- NWサーバーをシャットダウンします。
- /nsr/tmp/下のコンテンツを削除します。

- NWサーバーを再起動すると、runtime rendered logは機能するようになります。

Affected Products

NetWorker
Article Properties
Article Number: 000186465
Article Type: Solution
Last Modified: 05 Aug 2021
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.