NetWorker: NetWorker 업그레이드 후에 런타임 렌더링(daemon.log)이 더 이상 작동하지 않음

Summary: NW 19.3.0.4로 업그레이드한 후 런타임 렌더링(daemon.log)이 더 이상 작동하지 않습니다.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

- NW 업데이트 후 런타임 렌더링이 더 이상 작동하지않습니다.
- 데몬 로그가 더 이상 업데이트되지 않습니다.

Cause

- -NSR 로그의 NSR 로그 아래에 다음과 같은 많은 의심스러운 항목이 있습니다.

# nsradmin -p nsrexec
> p type:nsr log
...
..

type:nsr log
                        type: NSR log;
               administrator: root, "user=nsrnmc,host=nw-server1.vlab.local",
                              "user=root,host=nw-server1.vlab.local";
                       owner: nsrpolicy;
             maximum size MB: 2;
            maximum versions: 10;
        runtime rendered log:;
    runtime rollover by size: Disabled;
    runtime rollover by time:;
                        name: Group_name.raw;
                    log path: /nsr/logs/migration/Group_name.raw;
...
..
.
또는
...
..
.
 type: NSR log;
               administrator: root, "user=nsrnmc,host=nw-server1.vlab.local",
                              "user=root,host=nw-server1.vlab.local";
                       owner: Adhoc job log;
             maximum size MB: 2;
            maximum versions: 10;
        runtime rendered log: ;
    runtime rollover by size: Disabled;
    runtime rollover by time: ;
                        name: adhoc-job-hMfdQc;
                    log path: /nsr/logs/adhoc/adhoc-job-hMfdQc;
...
.
                        type: NSR log;
               administrator: root, "user=nsrnmc,host=nw-server1.vlab.local",
                              "user=root,host=nw-server1.vlab.local";
                       owner: Adhoc job log;
             maximum size MB: 2;
            maximum versions: 10;
        runtime rendered log: ;
    runtime rollover by size: Disabled;
    runtime rollover by time: ;
                        name: adhoc-job-9Q4xBr;
                    log path: /nsr/tmp/adhoc/adhoc-job-9Q4xBr;
...
..
.



- gstd, nsrim, nsrcpd, daemon과 같은 NSR 로그 아래에 "필수" 항목만 있는지 확인합니다.

예:
# nsradmin -p nsrexec
nsradmin> show name
nsradmin> p type:nsr log
                       owner: nsrim;
                        name: nsrim.raw;

                       owner: NetWorker;
                        name: daemon.raw;

                       owner: NetWorker;
                        name: nsrcpd.raw;

                       owner: nsrdsa_recover;
                        name: nsrdsa_recover.raw;

                       owner: NMC Log Fuile;
                        name: gstd.raw;

                       owner: nsrdsa_save;
                        name: nsrdsa_save.raw;
nsradmin>

Resolution

­ nsrladb의 복제본을 만듭니다.
- 의심스러운 항목을 검색하여 제거합니다.
- 항목은 "Adhoc" 또는 "migration"일 수 있습니다(다른 항목일 수도 있음).

- nsradmin(대화형 모드) 또는 입력 파일을 사용하여 해당 항목을 삭제합니다.

예:
# vi del_adhoc
delete owner:Adhoc job log;

# nsradmin -p nsrexec -i del_adhoc
 

- NSR 로그(예: gstd, nsrim, nsrcpd, daemon) 아래에 "필수" 항목만 있는지 확인합니다.

예:
# nsradmin -p nsrexec
nsradmin> show name
nsradmin> p type:nsr log
                       owner: nsrim;
                        name: nsrim.raw;

                       owner: NetWorker;
                        name: daemon.raw;

                       owner: NetWorker;
                        name: nsrcpd.raw;

                       owner: nsrdsa_recover;
                        name: nsrdsa_recover.raw;

                       owner: NMC Log Fuile;
                        name: gstd.raw;

                       owner: nsrdsa_save;
                        name: nsrdsa_save.raw;
nsradmin>


- shutdown NW Server
- delete content under /nsr/tmp/

- start NW Server, runtime rendered log is now working

Affected Products

NetWorker
Article Properties
Article Number: 000186465
Article Type: Solution
Last Modified: 05 Aug 2021
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.