NetWorker: a renderização em tempo de execução (daemon.log) não funciona mais após o upgrade do NetWorker

Summary: A renderização em tempo de execução (daemon.log) não funciona mais após o upgrade para o NW 19.3.0.4

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

— A renderização em tempo de execução não funciona mais após a atualização do NW
— O log do daemon não será mais atualizado

Cause

— o log NSR tem muitas entradas suspeitas, como:

# nsradmin -p nsrexec
> p type:nsr log
...
..

type:nsr log
                        type: NSR log;
               administrator: root, "user=nsrnmc,host=nw-server1.vlab.local",
                              "user=root,host=nw-server1.vlab.local";
                       owner: nsrpolicy;
             maximum size MB: 2;
            maximum versions: 10;
        runtime rendered log:;
    runtime rollover by size: Disabled;
    runtime rollover by time:;
                        name: Group_name.raw;
                    log path: /nsr/logs/migration/Group_name.raw;
...
..
.
OU
...
..
.
 type: NSR log;
               administrator: root, "user=nsrnmc,host=nw-server1.vlab.local",
                              "user=root,host=nw-server1.vlab.local";
                       owner: Adhoc job log;
             maximum size MB: 2;
            maximum versions: 10;
        runtime rendered log: ;
    runtime rollover by size: Disabled;
    runtime rollover by time: ;
                        name: adhoc-job-hMfdQc;
                    log path: /nsr/logs/adhoc/adhoc-job-hMfdQc;
...
.
                        type: NSR log;
               administrator: root, "user=nsrnmc,host=nw-server1.vlab.local",
                              "user=root,host=nw-server1.vlab.local";
                       owner: Adhoc job log;
             maximum size MB: 2;
            maximum versions: 10;
        runtime rendered log: ;
    runtime rollover by size: Disabled;
    runtime rollover by time: ;
                        name: adhoc-job-9Q4xBr;
                    log path: /nsr/tmp/adhoc/adhoc-job-9Q4xBr;
...
..
.



— certifique-se de deixar apenas as entradas "obrigatórias" no log NSR, como gstd, nsrim, nsrcpd, daemon

Por exemplo:
# nsradmin -p nsrexec
nsradmin> show name
nsradmin> p type:nsr log
                       owner: nsrim;
                        name: nsrim.raw;

                       owner: NetWorker;
                        name: daemon.raw;

                       owner: NetWorker;
                        name: nsrcpd.raw;

                       owner: nsrdsa_recover;
                        name: nsrdsa_recover.raw;

                       owner: NMC Log Fuile;
                        name: gstd.raw;

                       owner: nsrdsa_save;
                        name: nsrdsa_save.raw;
nsradmin>

Resolution

— Faça uma cópia de nsrladb
— Pesquise entradas suspeitas e as remova
— As entradas podem ser "Adhoc" ou "migration" (mas outras entradas são possíveis):

— Exclua essas entradas usando nsradmin (modo interativo) ou por meio do arquivo de entrada

Por exemplo
# vi del_adhoc
delete owner:Adhoc job log;

# nsradmin -p nsrexec -i del_adhoc
 

— Certifique-se de deixar apenas as entradas "obrigatórias" no log NSR (por exemplo: gstd, nsrim, nsrcpd, daemon)

Por exemplo:
# nsradmin -p nsrexec
nsradmin> show name
nsradmin> p type:nsr log
                       owner: nsrim;
                        name: nsrim.raw;

                       owner: NetWorker;
                        name: daemon.raw;

                       owner: NetWorker;
                        name: nsrcpd.raw;

                       owner: nsrdsa_recover;
                        name: nsrdsa_recover.raw;

                       owner: NMC Log Fuile;
                        name: gstd.raw;

                       owner: nsrdsa_save;
                        name: nsrdsa_save.raw;
nsradmin>


- shutdown NW Server
- delete content under /nsr/tmp/

- start NW Server, runtime rendered log is now working

Affected Products

NetWorker
Article Properties
Article Number: 000186465
Article Type: Solution
Last Modified: 05 Aug 2021
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.