NetWorker: savefs in hung state
Summary:
When backup is initiated from the backup server side, it stops responding. Running "savefs -D9 -vvvvv -p -s " on the client also stops responding. Client-side backups are
working fine.
...
Symptoms
When backup is initiated from the backup server side, it stops responding. Running "savefs -D9 -vvvvv -p -s <server_name>" on the client also stops responding. Client-side backups are working fine.
"Event view logs" on the problem client show:
CAPI2, event 513 Cryptographic Services failed while processing the OnIdentity() call in the System Writer Object. Details: AddLegacyDriverFiles: Unable to back up image of binary Microsoft Link-Layer Discovery Protocol. System Error: Access is denied. Service Control Manager 7011 A timeout (30000 milliseconds) was reached while waiting for a transaction response from the swprv service.
The command "vssadmin list shadows" stops responding.
Trying to list shadow copies using "diskshadow" command also stops responding while querying for shadow copies.
Trying to check the Shadow copies using UI through the C:\ drive properties are also stopping responding.
Cause
From Services, notice the Microsoft Software Shadow Copy Provider service (swprv) is stopping responding. It is seen in "Starting" state.
Escalation 39602 - savefs is hanging for Client BEDGT-MBSPAPP02 (file system + SQL Agent)
As per ESC, Savefs.exe tries to get the list of snapshots available on the System by calling to Microsoft API Call ivssbackupcomponents::query.
This Microsoft never returns, and hence savefs.exe gets into a hung state.
Resolution
Engage Microsoft Support to investigate why the Microsoft Software Shadow Copy Provider service (swprv) is stopping responding.
The server-side backups work once you reboot the Client machine and ensure the Microsoft Software Shadow Copy Provider service (swprv) is running.
Ensure the "vssadmin list shadows" command is working fine.