IDPA - VM backup stuck at waiting client due to proxy appearing as a local host

Summary: Backup stuck in waiting client due to proxy appearing as a local host.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

VMWare Backups fails with WAITING_CLIENT and then eventually times out with no progress bytes.

The following error can be observed in /usr/local/avamarclient/var/avagent.log:
avagent Error <6210>: Unable to register 'localhost' with MCS at <FQDN of Avamar Utility Node>:28001

Cause

vami set hostname file was not updated with correct proxy name.

Resolution

  1. Make sure that proxy is reachable and added in DNS by open cmd or avamar and try to ping IP. 
  2. Reboot the proxy and login again. If the problem persists, proceed with below steps. 
  3. Run nslookup <IP>  to get correct name of the proxy.
  4. Log into the proxy via ssh using putty with the username admin and then change to root. The default password is avam@r .
  5. Run  cd /opt/vmware/share/vami/
  6. Run vi vami_set_hostname and look for the variable: HOSTNAME="localhost.localdom"
  7. Change the "localhost.localdom" to the proxy name from step 3.
  8. ​Reboot the proxy.
  9. Login again to proxy and make sure that short hostname is reflected by running the following commands: cat /etc/HOSTNAME and  cat /etc/hosts
  10. ​​​​​​​if the hostname is not reflected, run vi /etc/HOSTNAME and vi/etc/hosts and add the short name.
  11. ​​​​​​​​​​​​​​​In vCenter, power off and power on the proxy, so that the DHCP server will correctly update the DNS entry on the DNS in use by the utility node and also the proxy.
  12. Verify that proxy server is browsable:
•    From Avamar GUI, go to “backup & restore” tab.
•    Choose your proxies from left panel.
•    Make sure that you can browse the Linux filesystem and list below directories.

 
​​​​​​​​​​​​​​​​​​​​​
 
​​​​​​​​​​​​​​​​​​​​​

 

Affected Products

PowerProtect Data Protection Appliance, Avamar Client
Article Properties
Article Number: 000187216
Article Type: Solution
Last Modified: 10 Jan 2022
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.