PowerStore : Les sessions de réplication asynchrone sont désynchronisées, sont dans l’état System_Paused, ne progressent pas ou affectent la stabilité du nœud

Summary: La réplication de volume PowerStore semble ne pas se synchroniser après un redémarrage récent du nœud ou un autre redémarrage pendant la mise à niveau sans perturbation. Cette condition a un impact sur la stabilité du système si elle n’est pas résolue. Le redémarrage du nœud peut se produire peu de temps après la création d’une nouvelle session de réplication. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Le système signale des réplications désynchronisées et le système interrompt l’activité.

Une alerte est déclenchée sur l’interface utilisateur :
Une session de réplication qui se trouve à cet état ne peut pas synchroniser les données entre le cluster local et le cluster distant tant que le problème n’est pas résolu. La perte de données maximale admissible (RPO) pour cette session n’est peut-être pas conforme.

Indications du journal ou de l’alerte :
May 11 22:53:26.629200 ::: B_ALERT volume Major A replication session associated with resource Test-Repl2 is in System_Paused state because of error: Transit object with Handle cbcf96ea-e8c8-4d88-8024-4bc507d7ac7c:34:761 : status not available.

La session de réplication tente également une suppression et une recréation, après quoi la session n’affiche plus aucune progression.
  • Cette condition entraîne le redémarrage du nœud PowerStore.

Cause

Le problème est lié à la mise en réseau, car une modification récente apportée à la MTU du réseau de stockage n’était pas cohérente avec l’infrastructure réseau de l’utilisateur.

Dans une situation spécifique, l’utilisateur a modifié le réseau de stockage (couche de transport de réplication asynchrone) de la valeur standard MTU de 1500 à 9000.

Resolution

La MTU doit avoir une configuration cohérente sur l’ensemble du réseau de l’utilisateur.
La création d’un réseau MTU incohérent rompt la relation de réplication et affecte la stabilité de PowerStore, car les nœuds finissent par redémarrer en raison de cette mauvaise configuration.

Rétablissez la configuration du réseau de stockage à la valeur MTU de 1500.
Cela permet à la réplication de reprendre son fonctionnement sans aucune autre action requise.

Remarque :
Si l’outil de validation (« Verify and Update » sous Protection/Remote System dans l’interface utilisateur PowerStore) peut afficher une connexion correcte au site distant, le support nécessite l’utilisation du test ping de la source à la reprise après sinistre et inversement avec une taille de paquet spécifique pour tester et confirmer que le transport MTU 9000 ne fonctionne pas.

Additional Information

Dans un scénario supplémentaire, la réplication peut également afficher une non-progression lorsque les deux réseaux de stockage sur les sites sources et distants sont configurés avec la même plage d’adresses IP. Il s’agit d’une situation rare qui peut se produire en raison d’une erreur humaine lors de la mise en œuvre initiale.

Le problème n’est pas lié à l’article suivant :
KB 185143 : PowerStore : Après la mise à niveau sans perturbation du cluster PowerStore, la synchronisation de la session de réplication passe à l’état System_Paused.

Affected Products

PowerStore
Article Properties
Article Number: 000187268
Article Type: Solution
Last Modified: 26 Dec 2022
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.