Data Domain Virtual Edition (DDVE) deployed on Azure cloud platform may hung during normal system reboot or during system upgrade

Summary: Data domain Virtual Edition (DDVE) deployed on Azure cloud platform may hung during normal system reboot via CLI or during system upgrade

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

System will hang during reboot process and following errors will be reported on Serial Console on Azure portal. 

DDR configuration completed.
Shutting down kernel logger: ( CHECKED )
Shutting down system logger: ( CHECKED )
Starting system logger: ( CHECKED )
Starting kernel logger: ( CHECKED )
[Stopwatch] Log file was dumped to: /ddr/var/log/debug/platform/boot_time.log

EMC Data Domain Virtual Edition
INIT: Sending processes the TERM signal
INIT: Sending processes the KILL signal
Stopping xinetd: ( CHECKED )
Stopping crond: ( CHECKED )
Shutting down kernel logger: ( CHECKED )
Shutting down system logger: ( CHECKED )
Starting killall: ( CHECKED )
[Stopwatch] Log file was dumped to: /ddr/var/log/debug/platform/boot_time.log
BOOT-TIME daemon is terminated
Sending all processes the TERM signal... dd_mon_kdeadman[9748]: caught signal:15 err:0 code:0 from pid:15958 uid:0

dd_mon_kdeadman[9748]: stat: 15958 (killall5) Z 15897 15897 15897 0 -1 4227340 672 0 0 0 0 0 0 0 20 0 1 0 125388 0 0 18446744073709551615 0 0 0 0 0 0 0 16384 0 1 0 0 17 4 0 0 0 0 0 0 0 0 0 0 0 0 0

dd_mon_kdeadman[9748]: stopped

Sending all processes the KILL signal...
Setting reboot watchdog for 300 seconds
Saving random seed:
Syncing hardware clock to system time
Turning off swap:
Unmounting file systems:
Please stand by while rebooting the system...
stop reboot watchdog...            

Cause

Dell EMC engineering found code defect in kernel driver in which will prevent system reboot normally 

Following DDOS versions are impacted. 
All DDOS 7.0.x
All DDOS 7.1.x
DDOS 7.2.0.30 and earlier 
Note: Only DDVE systems running on Azure Cloud Platform are impacted due to old kernel driver.

Resolution

Dell EMC engineering fixed this issue in DDOS 7.2.0.40 and later versions.  Please upgrade system to DDOS 7.2.0.40 and later versions to prevent similar issue in future.

Workaround
If system is hung during normal reboot/system upgrade, login to Azure portal and restart DDVE 

Restarting VM from Azure portal


Affected Products

Data Domain
Article Properties
Article Number: 000187331
Article Type: Solution
Last Modified: 12 Nov 2021
Version:  3
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