nsrck SYSTEM warning Cannot lock file index for client '<Client Name>' (For mange åbne filer)

Summary: NetWorker-servere, der kører version 19.4.0.2 og 19.5.0.0, kan støde på et problem, hvor både automatiseret og manuel kørsel af NSRCK-kommandoer mislykkes med fejlen "for mange åbne filer". ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker-servere, der kører version 19.4.0.2 og 19.5.0.0, kan støde på et problem, hvor både automatiseret og manuel kørsel af NSRCK-kommandoer mislykkes med fejlen "for mange åbne filer".
  • NSRCK-udførelse som en del af serverbeskyttelsespolitikken vil mislykkes uden at vise en fejl eller fejl i brugergrænsefladen, fejlene logføres i politikloggen og Daemon.raw-filerne:
    • Politiklogfil
      • 96467 1624042989 2 1 24 15160 10448 0 Server.Domain.com nsrck SYSTEM advarsel 43 Kan ikke låse filindeks for klient '%s' (%s) 2 12 20 Client.Domain.com 24 19 For mange åbne filer
    • Daemon.raw
      • 71193 1622838475 0 0 0 5876 5980 0 Server.Domain.com. NSR-info 9 %s %s: %s 3 11 10 2935: Indeks 11 12 19362: Meddelelse 49 70 195146 32 Kontrolindeks for klient '%s'.  1 0 20 Client.Domain.com
      • 96467 1622838492 2 1 24 6444 7952 0 Server.Domain.com nsrck SYSTEM advarsel 43 Kan ikke låse filindeks for klient '%s' (%s) 2 12 20 Client.Domain.com 24 19 For mange åbne filer
  • Hvis du kører NSRCK via kommandolinjen, returneres følgende fejl:
    • nsrck SYSTEM warning Cannot lock file index for client '' (For mange åbne filer)
  • NetWorker Client File Indexes (CFI) vil fortsætte med at vokse og forbruge storage, hvilket kan medføre, at systemet bliver ustabilt, hvis al lagring forbruges på værtsdrevet
  • Sikkerhedskopierings- og gendannelsesopgaver kan mislykkes med jævne mellemrum, hvis de kører på samme tid som NSRCK

Cause

Dette problem er forårsaget af en kodefejl, der blev introduceret i den første version af 19.4.0.2 kumulativt hotfix (CHF) > 19.5.0.0.

Resolution

Produkt (operativsystem eller driftsmiljø)
 
NetWorker Server 19.4.0.3
NetWorker Server 19.5.0.1
Handlingstype
 
Anvend hotfix
Handling nødvendig
 
Anvend relevant hotfix baseret på den påvirkede version, der aktuelt er installeret
Hvem kan fuldføre handlingen
 
NetWorker-administrator
Problem behandlet i dette operativsystem, driftsmiljø eller software
 
 
Detaljer om løsning Løsning:
NetWorker-servere, der kører 19.4.0.2, skal anvende 19.4.0.3 Kumulativt hotfix (CHF) for at løse dette problem.

NetWorker-servere, der kører 19.5.0.0, skal anvende den kumulative programrettelse 19.5.0.1 for at løse dette problem.

Midlertidig løsning:
For at løse dette problem skal du øge antallet af tilgængelige filbeskrivelser på operativsystemniveau.  For Linux-systemer:

 
  1. For at sikre en vedvarende indstilling skal du redigere filen /etc/sysctl.conf:

# vi /etc/sysctl.conf
 
  1. Tilføj et konfigurationsspørgsmål på følgende måde:

fs.file-max =

hvor er et decimalnummer, der definerer det maksimale antal åbne filer.  32768 er den anbefalede indstilling for store NetWorker-implementeringer og er et godt udgangspunkt.

 
  1. Gem og luk filen. Du kan enten genstarte computeren eller indtaste følgende kommando for at tvinge alle processer til at hente den nye værdi:

# sysctl -p

(præference er en genstart).

Bemærk: For at løse problemet skal administratorer muligvis definere værdier, der er højere end det, der anbefales ovenfor, så alle systemer vil være forskellige.  Se i dokumentationen til operativsystemet for at få oplysninger om sikre driftsgrænser, når du øger disse værdier.
Løsningsovervejelser Det anbefales på det kraftigste, at Hotifx anvendes så hurtigt som muligt.

Det er vigtigt, at operativsystemfilbeskrivelsesværdierne gendannes til værdier inden for det område, der er defineret i ydeevne- og optimeringsvejledningen, når hotfixet er blevet anvendt.

Products

NetWorker
Article Properties
Article Number: 000188258
Article Type: Solution
Last Modified: 23 Aug 2022
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.