Dell Unity : Après la mise à niveau de Unity OE vers la version 5.1 ou ultérieure, les sauvegardes Veeam cessent de fonctionner

Summary: Les sauvegardes Veeam ne se terminent pas après la mise à niveau d’Unity OE vers la version 5.1 ou une version ultérieure. Il n’est pas clair si d’autres versions d’Unity OE ont des sauvegardes Veeam qui ne fonctionnent pas. (Corrigible par Dell) ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Les sauvegardes s’arrêtent avec le message d’erreur suivant :
ErrorCode: '16777239', Message: 'There is a syntax error in the command.  Please recheck the command syntax. (Error Code: 0x1000017)'.

Cause

Veeam s’est appuyé sur le résultat d’une commande UEMCLI :
uemcli /sys/general show -output csv -filter "System name, Model, Platform type, Product serial number"
Avant Unity OE version 5.1, la sortie contenait un champ appelé « Platform type » et répondait comme suit sur Unity :
Platform type = EMC Storage System
Ce champ est devenu obsolète dans le code OE 5.0 et a été entièrement supprimé dans le code OE 5.1. L’appel Veeam UEMCLI renvoie une erreur de syntaxe après la mise à niveau de Unity vers la version 5.1.


Mise à jour pour Unity 5.4

La ligne de commande uemcli /sys/general show n’inclut pas le champ Type de plate-forme. La sortie ci-dessous montre la requête de filtre Veeam qui a échoué.
20:23:04 service@APM00192427000 spa:~/user# uemcli /sys/general show -output csv -filter "System name, Model, Platform type, Product serial number"
Storage system address: 127.0.0.1
Storage system port: 443
HTTPS connection

Operation failed. Error code: 0x1000017
Command line parsing failed near "Platform type" token.
There is a syntax error in the command. Please recheck the command syntax. (Error Code:0x1000017)

20:23:14 service@APM00192427000 spa:~/user# uemcli /sys/general show -output csv -filter "System name, Model, Product serial number"
Storage system address: 127.0.0.1
Storage system port: 443
HTTPS connection

"System name","Model","Product serial number"
"APM00192427000","Unity 480","APM00192427000"
20:23:26 service@APM00192427000 spa:~/user# 

Resolution

Solution

Mettez à niveau votre installation Veeam vers Veeam B&R version 11a. Pour obtenir une assistance supplémentaire, contactez le support Ce lien hypertexte renvoie à un site Web extérieur à Dell Technologies.technique Veeam.

Si Unity exécute toujours OE version 5.1.0.0.5.394 et que Veeam ne peut pas être mis à niveau vers Veeam B&R version 11a, contactez le support technique Dell ou votre prestataire de services agréé en leur communiquant l’identifiant de cet article de la base de connaissances Dell.

Affected Products

Dell EMC Unity
Article Properties
Article Number: 000189458
Article Type: Solution
Last Modified: 25 Jul 2024
Version:  15
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.