Dell Unity:将 Unity OE 升级到版本 5.1 或更高版本后,Veeam 备份停止工作

Summary: 将 Unity OE 升级到版本 5.1 或更高版本后,Veeam 备份未完成。目前尚不清楚其他 Unity OE 版本是否使 Veeam 备份不起作用。 (戴尔可纠正)

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

备份停止,并显示以下错误消息:
ErrorCode: '16777239', Message: 'There is a syntax error in the command.  Please recheck the command syntax. (Error Code: 0x1000017)'.

Cause

Veeam 依赖于 UEMCLI 命令的输出:
uemcli /sys/general show -output csv -filter "System name, Model, Platform type, Product serial number"
在 Unity OE 版本 5.1 之前,输出包含一个名为“Platform type”的字段,在 Unity 上响应如下:
Platform type = EMC Storage System
此字段在 OE 5.0 代码中已弃用,并在 OE 5.1 代码中完全删除。在 Unity 升级到 5.1 后,Veeam UEMCLI 调用会返回语法错误。


Unity 5.4 更新

命令行 uemcli /sys/general show 不包括 字段平台类型。下面的输出显示失败的 Veeam 筛选器查询。
20:23:04 service@APM00192427000 spa:~/user# uemcli /sys/general show -output csv -filter "System name, Model, Platform type, Product serial number"
Storage system address: 127.0.0.1
Storage system port: 443
HTTPS connection

Operation failed. Error code: 0x1000017
Command line parsing failed near "Platform type" token.
There is a syntax error in the command. Please recheck the command syntax. (Error Code:0x1000017)

20:23:14 service@APM00192427000 spa:~/user# uemcli /sys/general show -output csv -filter "System name, Model, Product serial number"
Storage system address: 127.0.0.1
Storage system port: 443
HTTPS connection

"System name","Model","Product serial number"
"APM00192427000","Unity 480","APM00192427000"
20:23:26 service@APM00192427000 spa:~/user# 

Resolution

解决方案

将您的Veeam安装升级到Veeam B&R 11a版本。如需更多帮助,请联系 Veeam 技术支持 此超链接会将您带往 Dell Technologies 之外的网站。

如果 Unity 仍在运行 OE 版本 5.1.0.0.5.394,并且 Veeam 无法升级到 Veeam B&R 版本 11a,请联系戴尔技术支持或您的授权服务提供商,并引用此戴尔知识库文章 ID。

Affected Products

Dell EMC Unity
Article Properties
Article Number: 000189458
Article Type: Solution
Last Modified: 25 Jul 2024
Version:  15
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.