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AppSync: Service Plan fails after Copy Phase begins with “Create local copy phase for target application completed with errors.”

Summary: SQL Full local backup copy creation failed at create local copy phase with Error: Users may see Windows based Service Plans fail with the following error: Create local copy phase for TARGET APPLICATION completed with errors. When we check the Server log we find the failure occurs after this message is seen: Exception Occurred: NumberFormatException, Message: For input string: "" This may be seen following an upgrade. ...

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Symptoms


Users may see Windows based Service Plans fail with the following error:
 
Create local copy phase for Target Application completed with errors.

From Server log we see AppSync set the phasepit to failed:
 
08-09-2021 14:54:19.270 DEBUG [Thread-216 (ActiveMQ-client-global-threads)] [com.emc.archway.entitycommands.phasepit.entity.UpdatePhasePitCommandBean] <AppSync Server> [] 6e310519-6725-415f-a5d8-76a87924733b->>> Updating phasePitStatus to Failed
08-09-2021 14:54:19.473 DEBUG [Thread-216 (ActiveMQ-client-global-threads)] [com.emc.archway.entitycommands.phasepit.entity.UpdatePhasePitCommandBean] <AppSync Server> [] 6e310519-6725-415f-a5d8-76a87924733b->>> Done updating phasePitStatus Failed

 
Then shortly after we see the stacktrace for the failure.
 
08-09-2021 14:54:19.645 DEBUG [Thread-216 (ActiveMQ-client-global-threads)] [com.emc.archway.commands.serviceplan.RunPhaseCommandBean] <AppSync Server> [] 6e310519-6725-415f-a5d8-76a87924733b->>> Task deleted: RunPhaseCommandBean.run
08-09-2021 14:54:19.661 ERROR [Thread-216 (ActiveMQ-client-global-threads)] [com.emc.archway.commands.serviceplan.workflow.WorkflowDeployPhaseCommandBean] <AppSync Server> [] 6e310519-6725-415f-a5d8-76a87924733b->>> service call deployPhase threw an exception
08-09-2021 14:54:19.661 ERROR [Thread-216 (ActiveMQ-client-global-threads)] [com.emc.archway.commands.serviceplan.workflow.WorkflowDeployPhaseCommandBean] <AppSync Server> [] 6e310519-6725-415f-a5d8-76a87924733b->>> Exception Occurred: NumberFormatException, Message: For input string: ""
08-09-2021 14:54:19.661 ERROR [Thread-216 (ActiveMQ-client-global-threads)] [com.emc.archway.commands.serviceplan.workflow.WorkflowDeployPhaseCommandBean] [ISMTZAPPSYNC] [] 6e310519-6725-415f-a5d8-76a87924733b->>> +++The following stack trace is abbreviated.+++
08-09-2021 14:54:19.661 ERROR [Thread-216 (ActiveMQ-client-global-threads)] [com.emc.archway.commands.serviceplan.workflow.WorkflowDeployPhaseCommandBean] <AppSync Server> [] 6e310519-6725-415f-a5d8-76a87924733b->>> java.base/java.lang.NumberFormatException.forInputString(NumberFormatException.java:65) [useful upper frame]
08-09-2021 14:54:19.661 ERROR [Thread-216 (ActiveMQ-client-global-threads)] [com.emc.archway.commands.serviceplan.workflow.WorkflowDeployPhaseCommandBean] <AppSync Server> [] 6e310519-6725-415f-a5d8-76a87924733b->>> java.base/java.lang.Integer.parseInt(Integer.java:662) [useful upper frame]
08-09-2021 14:54:19.661 ERROR [Thread-216 (ActiveMQ-client-global-threads)] [com.emc.archway.commands.serviceplan.workflow.WorkflowDeployPhaseCommandBean] <AppSync Server> [] 6e310519-6725-415f-a5d8-76a87924733b->>> java.base/java.lang.Integer.parseInt(Integer.java:770) [useful upper frame]
08-09-2021 14:54:19.661 ERROR [Thread-216 (ActiveMQ-client-global-threads)] [com.emc.archway.commands.serviceplan.workflow.WorkflowDeployPhaseCommandBean] <AppSync Server> [] 6e310519-6725-415f-a5d8-76a87924733b->>> deployment.archway-ear.ear//com.emc.archway.objectmodel.serviceplan.PhasePit.getVSSCopyRetryCount(PhasePit.java:502)

 
Above we see that AppSync has found a NULL value (Exception Occurred: NumberFormatException, Message: For input string: "") while looking for the VSSCopyRetryCount.

Cause

This issue is caused by the VSS Retry Count being left empty in the Service Plan.

Resolution

To resolve this issue do the following:
 
1.    Open the AppSync GUI and Click on Copy Management 

2.    Select Service Plans under the Copies drop down and select the affected Application (EG SQL or File System)

3.    Highlight the Service Plan which is failing and click on Edit in the right hand pane.

4.    Click Next.

5.    In the Create the Copy page check that there is a value present in the Retry Count field under  Advanced Plan Settings – VSS Retry Options.

6.    Click Next until the Finish button becomes available. 

7.    Retry the Service Plan to confirm the issue is resolved. 

Affected Products

AppSync
Article Properties
Article Number: 000190847
Article Type: Solution
Last Modified: 22 Oct 2024
Version:  5
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