Avamar: Odpojení okamžitého přístupu selže s chybou Invalid Client-List během obnovení IA

Summary: Odpojení okamžitého přístupu (IA) na systému Avamar selže s chybou "Invalid client-list", protože klient NFS (Network File System) hostitele ESXi již v systému Data Domain neexistuje.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Chyba odpojení okamžitého přístupu

Pokus o odpojení datového úložiště s okamžitým přístupem (IA) ze systému Avamar se nedokončí a zobrazí chybu.

  • V uživatelském rozhraní Avamar se zobrazí "Invalid client-list" Chybová zpráva během operace odpojení.
  • Proces odpojení čeká na vyřízení a nikdy nedosáhne úspěšného stavu.
  • Klient NFS přidružený k cestě exportu IA není při dotazu na systém Data Domain uveden.

 

Cause

Hlavní příčina selhání odpojení IA.

Operace odpojení IA se nezdaří s příkazem Invalid client‑list chyba, protože klient NFS (hostitel ESXi) používaný pro obnovení IA již není v konfiguraci Data Domain přítomen.

  • Seznam klientů Data Domain NFS neobsahuje hostitele ESXi, který inicioval obnovení IA.
  • Pokud klient chybí, systém Data Domain nemůže vyřešit cestu exportu, což má za následek Invalid client‑list Chyba při odpojování.
  • V případě, že se /data oddíl na zařízení Data Domain není připojen, exportní adresář IA se stane nepřístupným, což může také vyvolat stejnou chybu.

Příklad chybějícího klienta NFS v systému Data Domain:

# nfs show clients
No NFS clients found.

 

Příklad současného klienta NFS (pro srovnání):

# nfs show clients
Path                                            Client          Options
------------------------------------------------ ---------------- ------------------------------
/data/col1/avamar-XXXXXXXXXX/VMDS/Avamar-MOD-XXXXXXXXXXXXX  X.X.X.X  (sec=sys,rw,no_root_squash,no_all_squash,secure,version=3)

Resolution

Postup řešení chyby "Invalid client-list" během okamžitého připojení přístupu.

Požadavky

  • Přístup k uživatelskému rozhraní Avamar.
  • Přístup SSH k systému Data Domain s oprávněními správce.
  • Síťová konektivita mezi hostitelem ESXi a zařízením Data Domain.

Postup řešení krize

  1. Identifikujte ID úlohy okamžitého přístupu (IA).
    Použijte uživatelské rozhraní Avamar: Datová > úložiště Server Data Domain NFS. Poznamenejte si zobrazené ID úlohy IA.
  2. Potvrďte IP adresu hostitele ESXi.
    Spusťte vyhledávání DNS (Domain Name System) pro plně kvalifikovaný název domény (FQDN) hostitele ESXi a ověřte, zda vrácená IP adresa odpovídá hostiteli.
    nslookup
  3. Zkontrolujte stávající mapování klientů NFS v systému Data Domain.
    nfs show clients
     Pokud se hostitel ESXi zobrazí v seznamu, zkuste jej nejprve odpojit z uživatelského rozhraní Avamar. Pokud se nezobrazí, pokračujte.
  4. Ověřte ID uzlu ochrany dat (DPN) serveru Avamar.
    avmaint hfscreate
     Výstup zobrazí ID DPN (jako v, XXXXXXXXXX). Tuto hodnotu si poznamenejte pro pozdější kroky.
  5. Ujistěte se, že /data oddíl je připojen v systému Data Domain.
    df -h
     Když /data není uveden, připojte jej:
    mount localhost:/data /data
     Opakovat df -h potvrďte montáž.
  6. Vyhledejte metadata obnovení IA (create.xml).
    Nahradit XXXXXXXXXX s dříve získaným ID DPN.
    cd /data/col1/avamar-XXXXXXXXXX/VMDS/
    ls -l Avamar-MOD-XXXXXXXXXXXXX.vmds.info
    cat Avamar-MOD-XXXXXXXXXXXXX.vmds.info/create.xml
     Když create.xml existuje, pokračujte. Pokud ne, export IA již může být zúčtován.
  7. Namapujte hostitele ESXi na zastaralou cestu exportu IA.
    Použijte úplnou cestu exportu a IP adresu hostitele ESXi.
    nfs add /data/col1/avamar-XXXXXXXXXX/VMDS/Avamar-MOD-XXXXXXXXXXXXX
     Upozorňujeme, že příkaz je zastaralý. Systém navrhuje použít:
    nfs export
     Ale stále vytváří mapování.

     

  8. Ověřte nové mapování klienta NFS.
    nfs show clients
     Ujistěte se, že se IP adresa hostitele ESX zobrazuje se správnou cestou exportu a možnostmi.
  9. Odpojte datové úložiště Data Domain NFS z uživatelského rozhraní Avamar.
    Přejděte k položce datového úložiště a vyberte Odpojit. Po úspěšném odpojení se zobrazí potvrzovací obrazovka.
  10. Potvrzení odebrání klienta NFS v systému Data Domain.
  11. Znovu spusťte příkaz client-list:
nfs show clients

Hostitel ESXi by již neměl být uveden v seznamu.

Ověření

  • Zkuste další odpojení IA od softwaru Avamar. Operace by se měla dokončit bez "Invalid client‑list" .
  • V uživatelském rozhraní Avamar vyhledejte stav čisté úlohy IA.
  • Ověřte, zda v systému Data Domain neexistují žádné zbytkové položky klienta NFS.

 

VAROVÁNÍ: Úprava mapování klienta NFS a připojení /data Oddíl může ovlivnit probíhající operace zálohování nebo obnovení. Tyto kroky proveďte během časového období údržby nebo když je úloha IA nečinná.
VÝSTRAHA:  Nesprávná montáž nebo demontáž /data Oddíl může vést k nedostupnosti dat. Než budete pokračovat, ověřte přípojný bod.
POZNÁMKA: Pokud si některým krokem nejste jisti nebo pokud problém přetrvává i po provedení tohoto postupu, požádejte o pomoc podporu společnosti Dell.

Affected Products

Avamar
Article Properties
Article Number: 000192087
Article Type: Solution
Last Modified: 23 Oct 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.