Kan Update-Manager niet verwijderen na het installeren van de patch

Summary: Klant heeft SRM 4.6 bijgewerkt naar 4.6.0.1 en heeft een foutmelding ontvangen dat update-manager niet kan worden verwijderd

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Eerst werd een foutmelding ontvangen.
De geïnstalleerde module Update-Manager 7.3.0.2 heeft geen schone status en mag dus niet worden gebruikt. Het is zeer waarschijnlijk dat de vorige bewerking (installatie of update) niet is voltooid. Het wordt aanbevolen om het besturingssysteem op te lossen:

Nadat we Update-Manager op een schone status hadden ingesteld, konden we update-manager niet verwijderen zoals vereist als onderdeel van het updateproces-script.  

Cause

De oorzaak was tweeledig:
1. Module Update-Manager 7.3.0.2 heeft geen schone status.
2. Wanneer wordt geprobeerd de update-manager te verwijderen, volgt de manage-module voor het verwijderen van update-manager 7.3 de stappen, maar wordt nooit voltooid of afgebroken met fouten, omdat /opt/APG/Tools/Module-Manager/1.16.4/logs vol zijn met grote zip-bestanden en niet kunnen worden opgeschoond.  

Resolution

1. Update-Manager instellen op een schone status: ga naar /opt/APG/Tools/Module-Manager/1.16.4/data/update-manager-7.3
VI STATUS-bestand en wijzig DIRTY in INSTALLED. Hiermee wordt update-manager op een schone status ingesteld.

2. Het verwijderingsprobleem met update-manager oplossen:  Ga naar /opt/APG/Tools/Module-Manager/1.16.4/ en wijzig de naam van de logboekdirectory.  Maak een nieuwe logboekdirectory 
  1. mv -f logs logsold
  2. mkdir logs
  • Verwijder update-manager 
  • Manage-module voor het verwijderen van update-manager 7.3
  • Hiermee wordt de module verwijderd. 
Article Properties
Article Number: 000192198
Article Type: Solution
Last Modified: 08 Sep 2025
Version:  7
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.