Isilon : Patch and Drive Support Package installs fail with "failed to stage patch"

Summary: When attempting to install a patch or the Drive Support Package an error may be seen of "failed to stage patch". This knowledge base article covers how to resolve this.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When attempting to install a patch or install the Drive Support Package, the output includes "failed to stage patch" similar to the following outputs.

Example patch install failure:
Isilon-1# isi upgrade patches install HealthCheck_9.2.1_2021-09.pkg --simultaneous
The below patches are deprecated by this patch and will be removed automatically:
- HealthCheck_9.2.1_2021-06
Would you like to proceed? (yes/[no]): yes
failed to stage patch
Isilon-1#

Example Drive Support Package install failure:
Isilon-1# isi_dsp_install -q -d Drive_Support_v1.38.1.tar
DSP Install Start: Tue Oct 5 14:25:39 2021
Checking if Drive_Support_v1.38.1 is installed ...
Package Drive_Support_v1.38.1 is NOT installed
Installing Drive_Support_v1.38.1 ...
Running local CHECKS for patch Drive_Support_v1.38.1
New Version: Isilon OneFS 9.2.1.3 (Patch, Build B_9_2_1_002(RELEASE), 2021-07-16 01:19:00, 0x902015000000002, 9.2.1.3_GA-RUP_2021-08_PSP-1394)
ERROR: Patch install /ifs/data/Isilon_Support/dsp/Drive_Support_v1.38.1.tar: rc=failed to stage patch
Checking if Drive_Support_v1.38.1 is installed ...
Package Drive_Support_v1.38.1 is NOT installed
WARNING: /ifs/data/Isilon_Support/dsp/Drive_Support_v1.38.1.tar is not installed
Filter logdata to 2021-10-05 14:25:39 or later: 1 of 46 lines remain
Found 1 informational messages in isi_dsptool logfile
- 2021-10-24 19:41:43 INFO newsyslog[794]: logfile first created
DSP Install Failed, 29.5637869835 sec elapsed
Isilon-1#


Cause

The permissions of the patch file are preventing it from being installed.

Resolution

The commands that follow will change ownership of the file to a local user and group account and clear existing ACL information.  Take care to replace filename with the name of the file for the patch or Drive Support Package that is being installed.

Change the ownership of the file to the user, root [for Compliance Mode enabled clusters, replace the user root with compadmin], and the group, wheel.
chown root:wheel filename

Clear existing ACL information by running the following commands:
chmod -b 644 filename

Attempt to install the patch or Drive Support Package

Affected Products

PowerScale OneFS
Article Properties
Article Number: 000192206
Article Type: Solution
Last Modified: 12 Jan 2023
Version:  5
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