Dell Unity:CAVA 逾時可能會導致 SP 意外重新開機 (使用者可修正)

Summary: 在低於 5.1.x 的所有 Unity OE 程式碼版本中,CAVA 要求逾時可能會超過另一個作業的逾時,導致該作業失敗且 SP 發生錯誤。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

SP 當機,內部系統服務 (pool-SYSTEM_POOL) 出現錯誤代碼 12dc501。
在某些情況下,這可能發生在兩個 SP 上,並導致 DU。

Cause

CAVA 逾時的根本原因是 CAVA 組態中列出的數個不再存在的 CAVA 伺服器。  CAVA 正在等待來自這些伺服器的活動訊號回應。  在 5.1.x 之前的所有代碼版本中,CAVA 的預設要求逾時為 300 秒。  

在一個客戶案例中,文件系統檢查點卸載線程正在等待 CAVA 請求線程完成,但 CAVA 超時設置為 300 秒,檢查點卸載超時設置為 210 秒。  卸載未能及時完成,導致 SP 死機。

Resolution

  1. 請注意 CAVA 組態中列出的 IP 位址。  確保僅列出活動 CAVA 伺服器的 IP 位址,以避免任何不必要的通信超時。
  2. Dell Unity OE 5.1.x 版會將預設的 CAVA 要求逾時從 300 秒變更為 120 秒。  升級到 5.1.x 可防止此問題發生。
  3. 在升級之前,客戶可以手動更改控制 CAVA 請求超時的參數。  登入 SSH 主控台,輸入以下命令:
svc_nas ALL -param -f viruschk -m requestTimeout -v 120000

此變更會立即發生。  此變更也會在 SP 重新開機後持續存在。  但是,預設超時將應用於創建的任何新 NAS 伺服器,因此每次創建新的 NAS 伺服器時都應運行此命令,直到代碼升級到 5.1.x。

Affected Products

Dell EMC Unity
Article Properties
Article Number: 000192245
Article Type: Solution
Last Modified: 29 Aug 2022
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.