Dell EMC Unity: Tabela wydajności nie jest dostępna, ponieważ partycja /EMC/backend/metricsluna1 jest pełna w 100%
Summary: Użytkownicy stwierdzili, że tabela wydajności nie jest dostępna w kodzie Unity 5.1.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Tabela wydajności jest niedostępna.
Logowanie do konsoli SSH pokazuje, że partycja metricsluna1 jest pełna:
Wyświetlanie użycia plików na tej partycji potwierdza wypełnienie archiwalnymi plikami:
Logowanie do konsoli SSH pokazuje, że partycja metricsluna1 jest pełna:
root@XXXXXXXXXXXXX spb:/cores/service/user# df -h Filesystem Size Used Avail Use% Mounted on udev 1.3G 8.0K 1.3G 1% /dev /dev/mapper/alteroot 13G 6.1G 6.1G 51% / tmpfs 17G 100M 17G 1% /dev/shm tmpfs 17G 1.6G 15G 10% /run tmpfs 17G 0 17G 0% /sys/fs/cgroup /dev/ram0 59M 2.1M 57M 4% /tmp /dev/sda7 128G 2.1G 120G 2% /cores /dev/sda1 113M 1.9M 105M 2% /mnt/c4lx-cfg_msata /pramfs 122M 43M 80M 35% /pramfs /dev/mirrora5 57G 4.1G 51G 8% /EMC/backend/service /dev/c4nasdba2 3.5G 391M 2.9G 12% /EMC/backend/CEM /dev/c4nasdba1 997M 51M 895M 6% /nbsnas /dev/c4loga1 3.3G 80M 3.1G 3% /EMC/backend/log_shared /dev/c4loga2 4.6G 9.5M 4.3G 1% /EMC/backend/perf_stats /dev/metricsluna1 16G 16G 0 100% /EMC/backend/metricsluna1 /dev/c4fastvpa1 5.9G 855M 4.8G 15% /EMC/fastvp /dev/dm-7 9.8G 455M 8.9G 5% /var/lib/docker/devicemapper/mnt/852c05c74c281546e57fb096cbfe33bc1a50551d4c65ca180c00d78aa8f320e2
Wyświetlanie użycia plików na tej partycji potwierdza wypełnienie archiwalnymi plikami:
root@XXXXXXXXXXXXX spb:/cores/service/user# du -h /EMC/backend/metricsluna1/ |sort -hr |head -20 16G /EMC/backend/metricsluna1/ 15G /EMC/backend/metricsluna1/archives 1.2G /EMC/backend/metricsluna1/metricsdb/PG_10_201707211/16406 1.2G /EMC/backend/metricsluna1/metricsdb/PG_10_201707211 1.2G /EMC/backend/metricsluna1/metricsdb 16K /EMC/backend/metricsluna1/lost+found 4.0K /EMC/backend/metricsluna1/metricsdb/PG_10_201707211/pgsql_tmp
Cause
Po uaktualnieniu OE do wersji 5.1, jeśli macierz Unity włącza CloudIQ, występuje problem z kodem, który powoduje, że stare pliki archiwum wydajności nie zostaną usunięte w zapleczu. Ten problem ostatecznie prowadzi do zapełnienia partycji metricsluna1.
Jeśli macierz Unity spełnia poniższe dwa kryteria, oznacza to, że występuje ten problem z kodem:
Jeśli macierz Unity spełnia poniższe dwa kryteria, oznacza to, że występuje ten problem z kodem:
- Macierz Unity działa na kodzie 5.1.
- Funkcja CloudIQ jest włączona.
Resolution
Obejście problemu polega na ręcznym usunięciu starych plików archiwalnych przy użyciu metody tar z bazy wiedzy 191159: Dell EMC Unity: Uaktualnienie do kodu 5.1 może zakończyć się niepowodzeniem z powodu braku i-węzłów lub niespójności bazy danych metryk (możliwość naprawienia przez Dell EMC).
Uwaga: W razie potrzeby plik ten może być zapisany dla klienta w celu wykorzystania do zarchiwizowanych metryk.
Upewnij się, że plik tar jest prawidłowy:
Usuń pliki archiwalne, aby zwolnić miejsce:
Ten problem ma zostać rozwiązany w nadchodzącej wersji kodu.
Uwaga: W razie potrzeby plik ten może być zapisany dla klienta w celu wykorzystania do zarchiwizowanych metryk.
Aby zwolnić dostępne miejsce, wydaj następujące polecenia jako root:
- Zmień katalog na katalog główny.
- Wyślij pliki archiwalne do pliku tar w katalogu głównym.
root@APM00000000000 spa:~/home/service/user# tar cvfz metrics_archive.tgz /EMC/backend/metricsluna1/archives/
Upewnij się, że plik tar jest prawidłowy:
root@APM00000000000 spa:~/home/service/user# tar -tvf metrics_archive.tgz
Usuń pliki archiwalne, aby zwolnić miejsce:
root@APM00000000000 spa:~/home/service/user# rm /EMC/backend/metricsluna1/archives/_default*
- Sprawdź, czy dostępna jest wystarczająca ilość miejsca:
root@APM00000000000 spa:~/home/service/user# df -h
Ten problem ma zostać rozwiązany w nadchodzącej wersji kodu.
Affected Products
Dell EMC Unity, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity HybridArticle Properties
Article Number: 000192659
Article Type: Solution
Last Modified: 11 Aug 2025
Version: 6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.