PowerStore Alerts: System Full Capacity Alerts
Summary: This article discusses alerts for relating to full capacity Write Protect Mode (WPM) and the resulting alerts.
Symptoms
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Cause
For an explanation of how Physical Capacity is calculated, see KB article 188491: PowerStore: How PowerStore Physical Capacity is calculated.
Resolution
| Alert ID | DATA_PATH_WRITE_PROTECT_MODE_ENTER DATA_PATH_APP_EXIT_WPM_WITH_ENOUGH_MD_NOTIFY DATA_PATH_APP_WPM_SHORT_OF_MD_NOTIFY |
| Alert Text | The <user or system > data capacity has reached its full capacity. Appliance has exited the write protection state with 16 GB of free capacity. Appliance cannot exit the Write Protection mode due to insufficient system data capacity. |
| Error Code | (0x00200701) (0x00201401) (0x00201501) |
| Resolution | What happens when in Write Protect Mode (WPM) When an appliance reaches its full capacity, it enters a condition that is known as Write Protect Mode (WPM), where all volumes transition to read-only.
For an explanation of how Physical Capacity is calculated, see KB article 188491: PowerStore: How PowerStore Physical Capacity is calculated. The PowerStore Total Physical Capacity is comprised of both User Data and System Data. : When the system reaches 70% capacity, alerts are raised to warn of lack of space. See KB article 000123351: PowerStore Alerts: Capacity Utilization. If the user takes no action, and the system reaches 100%, the system enters Write Protect Mode (WPM), which indicates that all volumes enter read-only mode, and the alert 0x00200701 is raised. Alert 0x00200701 indicates space issue with either User Data or System Data. How do we know the root cause for the WPM: The user can determine the WPM condition root cause based on the alert text:
According to the type of WPM condition (User Data or System Data) the workaround is determined. Solution Recovering from OOS condition depends on the reason for the OOS. The cause of the WPM condition is contained in the alert text:
Depending on the type of WPM condition (User Data or System Data), the workaround is determined. 1. User DataUse one of the following options:
Additional information
2. System DataUse one of the following options:
In this example, deleting the below volume reclaims 59.8 GB of space that can be used for either User Data or System Data. Note that System Data requires a minimum of around 100 GB of unique space to be able to expand. Sometimes it may require 200 GB of space to properly expand. |
Additional information
- Usually, when an appliance enters WPM due to System Data, User Data also runs out of space.
This is because there is no capacity that is left for expanding (either System Data or User Data). - To get out of WPM, typically the user is required to add additional drives and scale up the appliance.
- When the system raises the alert 0x00200701 (Alert text: The System capacity has reached its full capacity.) , it indicates that System Data has run out of space and cannot be expanded.
- Avoid deleting volumes in this condition, and escalate to Global Services for support.
How to use svc_volume_space_metrics
- PowerStoreOS 1.0.3 introduced a service script that allows users when in WPM to see additional information about each volume tree.
- To run the script, SSH must be enabled on the specified appliance, and the user must connect using SSH to cluster IP using service account.
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When trying to run this service script when not in WPM, the service script fails.
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When appliance runs out of space, the user can run the script and see additional information, such as:
Family Unique Physical Used - This represents the unique data (compressed) this volume, and all its family (snapshots and clones) release if this volume is deleted.
Example:[SVC:service@68R1BW2-A user]$ svc_volume_space_metrics 2020-10-29 12:28:33,997 - INFO - event_client init() address: localhost node: A 2020-10-29 12:28:34,248 - INFO - PyCycloneDp.init localhost 2020-10-29 12:28:34,318 - PyCycloneDp - INFO - logging in PyCycloneDp.__init__ Namespace state is ro-oos Retrieve family space stats from DP namespace. It will take some time... 2020-10-29 12:28:35,972 - INFO - event_client init() address: localhost node: A 2020-10-29 12:28:36,175 - INFO - PyCycloneDp.init localhost 2020-10-29 12:28:36,220 - PyCycloneDp - INFO - logging in PyCycloneDp.__init__ --------------------------------------+------------------------------------------------------+-------------+----------------+----------------+-----------+---------- Family ID | Primary Volume/FS/vVol Name | Type | Family Unique | Family Shared | No. of | No. of | | | Physical Used | Logical Used | Clones | Snapshots --------------------------------------+------------------------------------------------------+-------------+----------------+----------------+-----------+---------- d301959c-6eb9-4e23-967a-e0b3cdf06bea | labtea-vol-1 |Block | 97.91 GB| 486.36 GB| 0 | 1 6c97fdd8-5b01-44ef-adaf-047449f83c27 | labtea-vol-2 |Block | 99.47 GB| 492.30 GB| 0 | 1
| Alert ID | DATA_PATH_WRITE_PROTECT_MODE_EXTREMELY_HIGH |
| Alert Text | The space utilization of %(tier_name) is extremely high. |
| Error Code | 0x00200703 |
| Impact | Several internal services (such as NAS and UI) may not operate optimally. |
| Resolution | Cause: Some of the appliance capacity is reserved for internal services (such as NAS core services, Data Collects, internal DB and more). When the appliance reaches Write Protect Mode (0x00200701), the user can no longer write any data, however internal services can still access critical information (only from PowerStoreOS 3.0), once the internal reserved capacity also runs out, this alert is raised, CP and SDNAS (and other services) may not operate optimally. Solution: Contact Technical Support for immediate assistance. |
Additional Information
- If a PowerStore Node is down for more than 30 minutes, capacity may increase over time more rapidly. For more information see PowerStore: Appliance may run into WPM (Write Protect Mode) or OOS (Out of Space) after a single node is down for more than 30 min.
- When deleting a volume, the space from deleted volumes is reflected quickly in the PowerStore Manager UI. However the space reclamation is done in the background, and may take some time to complete. It is recommended to wait several hours for the background processes to complete reclaiming the space.


