PowerStore Alerts: Physical Capacity Utilization

Summary: This article discusses alerts for lack of physical space and the resulting offline alerts.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When Dell PowerStore encounters an issue, an error alert is generated to help identify the issue. This article explains the different possible causes and the relevant remediation for these error alerts. If your issue is not resolved despite the remediation that is provided, check the technical support contact options.

 

NOTE: Cannot find the information needed? Let us know using the feedback form at the bottom of this article.

Cause

  1. Physical Capacity represents the usable capacity that the client can use for their applications, including the appliance data involved in managing all the appliance objects.
  2. The alerts below are raised when physical capacity for a specific appliance reaches predefined thresholds. Client actions may be required to avoid Write Protect Mode (WPM).
  3. When an appliance reaches its full capacity, it enters a condition that is known as Write Protect Mode (WPM). In WPM, all volumes transition to read-only, and a repair of the appliance is required.
  4. Alerts are raised when an appliance reaches 70% of its capacity and continue to be raised until the appliance runs out of space and enters Write Protect Mode (WPM).
  • Cluster performance may be impacted at excessive utilization levels.
  • Migration into this appliance may contribute to high space utilization.

General Recommendations:

  • Maintain less than 85% utilization rate per appliance.
  • Use a dataset that is in average not highly compressible (over 8:1).

Extra References

Resolution

Alert ID DATA_PATH_USER_TIER_CAPACITY_UTILIZATION_ABOVE_70_PERCENT
DATA_PATH_USER_TIER_CAPACITY_UTILIZATION_ABOVE_80_PERCENT
DATA_PATH_USER_TIER_CAPACITY_UTILIZATION_ABOVE_90_PERCENT
DATA_PATH_USER_TIER_CAPACITY_UTILIZATION_ABOVE_95_PERCENT
DATA_PATH_USER_TIER_CAPACITY_UTILIZATION_ABOVE_96_PERCENT
DATA_PATH_USER_TIER_CAPACITY_UTILIZATION_ABOVE_97_PERCENT
DATA_PATH_USER_TIER_CAPACITY_UTILIZATION_ABOVE_98_PERCENT
DATA_PATH_USER_TIER_CAPACITY_UTILIZATION_ABOVE_99_PERCENT
DATA_PATH_USER_TIER_CAPACITY_UTILIZATION_ABOVE_95_PERCENT_NDU
DATA_PATH_USER_TIER_CAPACITY_UTILIZATION_ABOVE_96_PERCENT_NDU
DATA_PATH_USER_TIER_CAPACITY_UTILIZATION_ABOVE_97_PERCENT_NDU
DATA_PATH_USER_TIER_CAPACITY_UTILIZATION_ABOVE_98_PERCENT_NDU
DATA_PATH_USER_TIER_CAPACITY_UTILIZATION_ABOVE_99_PERCENT_NDU
Alert Text
Capacity utilization is above 70 percent.
Capacity utilization is above 80 percent.
Capacity utilization is above 90 percent.
Capacity utilization is above 95 percent.
Capacity utilization is above 96 percent.
Capacity utilization is above 97 percent. 
Capacity utilization is above 98 percent.              
Capacity utilization is above 99 percent.   
Physical capacity utilization increased above 95% during NDU
Physical capacity utilization increased above 96% during NDU
Physical capacity utilization increased above 97% during NDU
Physical capacity utilization increased above 98% during NDU  
Physical capacity utilization increased above 99% during NDU       
Error Code (0x00200E01)
(0x00200E02)
(0x00200E03)
(0x00200E04)
(0x00200E05)
(0x00200E06)
(0x00200E07)
(0x00200E08)
(0x00200E0A)
(0x00200E0B)
(0x00200E0C)
(0x00200E0D)
(0x00200E0E)
Resolution  

Resolution varies depending on the type of alert and condition:

  • For alert codes 0x00200E01 - 0x00200E08, when the dataset is compressible less than 8:1, see Space Alerts with Standard Dataset sub section.
  • For alert codes 0x00200E01 - 0x00200E08, when the dataset is compressible higher than 8:1, see Space Alerts with Highly Compressible Dataset sub section.
  • For alert codes 0x00200E0A - 0x00200E0E, see Space Alerts During NDU sub section.
  • For other known issues related to Space Accounting, see Known Issues sub section.

Space Alerts with Standard Dataset

Alert and PowerStore Manager capacity do not match (alert shows 70%, UI shows 50%), use one of the following options to resolve it:

  1. Add more drives, as needed. For more information, reach out to your local account team for proper sizing.
  2. Delete unnecessary storage resources (volumes, snapshots, clones). The process of reclaiming space may take some time.
  3. Migrate to other appliances in the same cluster (only relevant for multi appliance cluster).
  4. Pause replication sessions, change Snapshot schedules or move replication to other appliances or /clusters.
  5. Perform Space reclamation - See your specific Operating System manual for instructions how to reclaim space using the Operating System.

Space Alerts with Highly Compressible Dataset 

Alert and PowerStore Manager capacity do not match (alert shows 70%, UI shows 50%), use one of the following options to resolve it:

  • A highly compressible dataset most likely causes this issue (over 8:1). To confirm, check the PowerStore Manager UI under Savings.
  • For example, in the screenshot below, the physical capacity is at 30%. If the appliance sent an alert on Physical Capacity is above 70%, it is most likely an indication for a highly compressible dataset:
Physical Capacity
  • Check the Data Savings pane. Data Reduction is a combination of the compression ratio and deduplication ratio. 
  • As a guideline, any Data Savings beyond 32:1 may indicate a dataset that is highly compressible, resulting in the raised capacity alert. 
Data savings 
 

Use one the following options to resolve the issue:

  1. Delete unnecessary storage resources (volumes, snapshots, clones). The process of reclaiming space may take some time.
  2. Migrate to other appliances in the same cluster (only relevant for multi appliance cluster).
  3. Pause replication sessions, Snapshot schedules, and move replication to other appliances or clusters.
  4. Perform Space reclamation - See your specific Operating System manual for instructions how to reclaim space using the Operating System.
 

Space Alerts During NDU

PowerStoreOS 3.0 adds several new alerts related to capacity utilization during NDU:

  1. Prior to NDU start, Pre Upgrade Health Check (PUHC) verifies that the appliance does not have more than 85% used capacity
  2. If for some reason, capacity utilization grows during NDU to high levels, special considerations must be considered
  3. While upgrade (NDU) is in progress, adding drives is not possible, meaning the workarounds to recover from Write Protect Mode (WPM) are limited extra care must be considered when receiving such alerts during NDU
  4. While upgrade (NDU) is in progress, several internal mechanisms are disabled, this includes internal space reclaim, this means that if NDU fails for any reason, the issue must be fixed as soon as possible.
    IMPORTANT: Do not keep appliances with failed NDU for a prolong duration

Use one the following options to resolve the issue:

  1. Reduce write I/O to the appliance that is about to run out of space until the NDU is complete.
  2. Delete unnecessary storage resources (volumes, snapshots, clones). The process of reclaiming space may take some time.
  3. Migrate to other appliances in the same cluster (only relevant for multi appliance cluster).
  4. Pause all replication sessions, Snapshot schedules, and migrations to this appliance
  5. Perform Space reclamation - See your specific Operating System manual for instructions how to reclaim space using the Operating System

     

     


    For Error Codes (0x00200701) (0x00201401) (0x00201501) relating to Write Protect Mode Capacity alerts in PowerStore, see KB article 193645: PowerStore Alerts: System Full Capacity Alerts:  


    For Error Codes (0x00200401) (0x00200501) relating to log data or metadata tier offline in PowerStore, see KB article 130637: PowerStore Alerts: Data Path Halt and Vault State Alerts


    Additional Information

    Known Issues:

    Affected Products

    PowerStore
    Article Properties
    Article Number: 000123351
    Article Type: Solution
    Last Modified: 19 Sep 2025
    Version:  18
    Find answers to your questions from other Dell users
    Support Services
    Check if your device is covered by Support Services.