Latitude Rugged Computers Cannot Boot to the Operating System Directly After Changing SATA Mode from Disable to Enable
Summary: This article provides information about a Latitude Rugged computer that cannot boot to the operating system directly after changing M.2 Serial AT Attachment (SATA) mode from OFF to ON.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Latitude Rugged computer may not be able to boot to the Operation System when disabled and enable the devices.
Affected Products:
- Latitude 5430 Rugged
- Latitude 7330 Rugged Extreme

Cause
No cause information is available.
Resolution
The boot order is added to the end of the boot order if re-enable the devices.
- Reboot the computer and press F2 key to go to the BIOS setting.
- Go to Boot Configuration and adjust the boot sequence as follows:
- Windows Boot Manager
- USB NIC (IPV4)
- USB NIC (IPV6)
- UEFI HTTPs Boot
- ONBOARD NIC (IPV4)
- ONBOARD NIC (IPV6)
- UEFI HTTPs Boot 2
- The name of the hard drive disk installed on the computer (In the example image below, "UEFI RST PM9A1 NVMe Samsung 256GB S65TNE0NC76878" is displayed)

Affected Products
Latitude 7330 Rugged Extreme, Latitude 5430 RuggedArticle Properties
Article Number: 000193865
Article Type: Solution
Last Modified: 16 Apr 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.