Dell EMC Networking OS10 在出现登录日志消息“syslog-ng.service is not active, cannot reload”(syslog-ng.service 不活动,无法重新加载)时,解决方法

Summary: 如果您在登录时看到消息“syslog-ng.service is not active, cannot reload”(syslog-ng.service 处于非活动状态,无法重新加载),请按照以下内容作以了解解决方法和问题。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

在登录到交换机后,登录到交换机后可能会看到以下行:
 
syslog-ng.service is not active, cannot reload


Cause


在极少数情况下, /var/lib/syslog-ng/syslog-ng.persist 可能会损坏。发生这种情况时, syslog-ng 服务 无法启动,将进入失败状态。

运行以下命令时,您会看到状态为失败。

OS10# system “sudo systemctl status syslog-ng”
syslog-ng.service - System Logger Daemon
Loaded: loaded (/lib/systemd/system/syslog-ng.service; enabled; vendor preset: enabled)
Active: failed (Result: core-dump) since Tue 2021-10-01 11:58:22 UTC; 3 周

Resolution

解决方法



可以通过删除 /var/lib/syslog-ng/syslog-ng.persist 文件并启动服务来启动失败的 syslog-ng.service

短期修复恢复服务,直到计划的升级-

OS10# system “sudo rm /var/lib/syslog-ng/syslog-ng.persist”
OS10# system “sudo systemctl start syslog-ng”
OS10# system “sudo systemctl status syslog-ng”

syslog-ng.service - System Logger Daemon
Loaded: loaded (/lib/systemd/system/syslog-ng.service; enabled; vendor preset
Active: active (running) since Thu 2021-10-28 22:05:58 UTC; 1min 35s ago


解决方案


升级到 10.5.2.2 或更高版本以解决问题。

Affected Products

SmartFabric OS10 Software
Article Properties
Article Number: 000193969
Article Type: Solution
Last Modified: 05 Jun 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.