PowerProtect Data Manager: errore di backup di Oracle RMAN: ORA-19506: failed to create sequential file, name="…/XXXXXXXX-XXXXXXXX-ff"

Summary: PPDM: errore di backup di Oracle RMAN: ORA-19506: failed to create sequential file, name="…/XXXXXXXX-XXXXXXXX-ff".

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Symptoms

Il backup di RMAN non viene completato in PowerProtect Data Manager (PPDM) con il messaggio:
ORA-19506: failed to create sequential file, name=”.../XXXXXXXX-XXXXXXXX-ff”

Cause

Il formato di Controlfile è impostato su un valore non accettabile. Oracle non è in grado di generare parti sequenziali. Il formato "%%F" non è valido.

Resolution

  1. Controllare il formato di Controlfile digitando il comando mediante RMAN:
RMAN> SHOW ALL;
CONFIGURE CONTROLFILE AUTOBACKUP FORMAT FOR DEVICE TYPE DISK TO '………/%%F';
CONFIGURE CONTROLFILE AUTOBACKUP FORMAT FOR DEVICE TYPE SBT_TAPE TO '%%F';
  1. Nel registro PPDM:
autobackup format for disk to  '................/controlfile_PRD21.20210923_200001_Tue.%%F.ctl';
  1. DBA deve impostare il valore sul formato predefinito (%F) o su un formato accettabile:
CONFIGURE CONTROLFILE AUTOBACKUP FORMAT FOR DEVICE TYPE DISK TO '………_%F';
CONFIGURE CONTROLFILE AUTOBACKUP FORMAT FOR DEVICE TYPE SBT_TAPE TO '………_%F';
  1. Per l'applicazione della configurazione è necessario attendere il giorno successivo in cui il timestamp di Controlfile viene modificato, generando una nuova sequenza di parti.
  2. Per verificare che la correzione funzioni, eseguire un nuovo backup o un backup manuale di Controlfile, per garantire che la parte termini con due cifre e non con "-ff":
RMAN> connect target /
RMAN> backup current controlfile;
".../2615403650-20210924-01"

Affected Products

DD Boost for Oracle RMAN
Article Properties
Article Number: 000194241
Article Type: Solution
Last Modified: 27 Aug 2022
Version:  3
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