PowerEdge: Windows - Il sistema si avvia con il messaggio "Errore C0190019 applicazione dell'operazione di aggiornamento"

Summary: Questo articolo descrive la procedura per risolvere una condizione di mancato avvio specifica in Windows: "Errore C0190019 durante l'applicazione dell'operazione di aggiornamento x di y (nome file)" ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Windows non si avvia e si blocca su una schermata che mostra il logo di Windows e il messaggio "Error C0190019 applying update operation x of y (filename)". I numeri rappresentati da x e y variano, così come il nome del file.

Cause

Sono note due possibili cause:

  1. L'unità C: è piena o quasi piena.
  2. Si verifica un problema durante il processo di aggiornamento di Windows.

Resolution

Quando si verifica questo problema, Windows non è in grado di avviarsi. L'avvio in modalità provvisoria genera la stessa schermata di errore. Windows Recovery Environment (WinRE) è l'unica opzione valida per la risoluzione dei problemi.

È possibile raggiungere WinRE avviando il supporto del sistema operativo. Se non è disponibile alcun supporto, il sistema si avvierà automaticamente anche in Ambiente ripristino Windows dopo diversi errori di avvio.

Una volta avviato il sistema in WinRE, effettuare le seguenti operazioni:

  1. Nel menu Scegli un'opzione , selezionare Risoluzione dei problemi.
  2. Nel menu Opzioni avanzate , selezionare Prompt dei comandi.
  3. Fornire le credenziali amministrative, se richiesto.
  4. Al prompt, digitare diskpart.
  5. Al Diskpart prompt, digitare list vol per determinare la lettera dell'unità del volume in cui è installato Windows. Può essere o meno C: in WinRE.
  6. Tipo exit chiudere Diskpart.
  7. Passare all'unità ottenuta nel passaggio 5.
  8. Tipo dir e controllare la quantità di spazio libero elencata nella parte inferiore dell'output.
  9. Se l'output del comando indica una mancanza di spazio libero, determinare quali file possono essere eliminati o spostati in un'altra unità. Dopo aver liberato spazio, riavviare il server. Se l'errore persiste, ripetere i passaggi da 1 a 7 prima di procedere.
  10. Eseguire il seguente comando per annullare eventuali aggiornamenti di Windows in sospeso, sostituendo X: con la lettera dell'unità ottenuta al passaggio 5: Il completamento di questo comando può richiedere diversi minuti.
    dism /image:X:\ /cleanup-image /revertpendingactions
  11. Al termine del comando, eseguire questo comando per verificare il danneggiamento nell'archivio componenti, sostituendo nuovamente X: con la lettera dell'unità del passaggio 5: Anche questo comando richiede un po' di tempo per essere completato.
    dism /image:X:\ /cleanup-image /scanhealth
    
  12. Se il comando precedente indica che l'archivio componenti è danneggiato, eseguire questo comando per tentare di ripararlo, sostituendo ancora una volta X: con la lettera dell'unità del passaggio 5: (Anche in questo caso, questo comando richiede un po' di tempo. Se il comando precedente non rileva alcun danneggiamento, ignorare questo passaggio.
    dism /image:X:\ /cleanup-image /restorehealth
  13. Digitare exit per chiudere il prompt dei comandi e tornare al menu Scegli un'opzione .
  14. Fare clic su Spegni il PC.
  15. Dopo che il sistema si è spento, riaccenderlo. Potrebbe eseguire un ripristino automatico all'avvio, ma dovrebbe poi avviarsi in Windows.

Affected Products

Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022, Microsoft Windows Server 2025, Poweredge C4140, PowerEdge C6420, PowerEdge C6520, PowerEdge C6525, PowerEdge C6615, PowerEdge C6620, PowerEdge FC640 , PowerEdge HS5610, PowerEdge HS5620, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge MX740C, PowerEdge MX840C, PowerEdge R260, PowerEdge R360, PowerEdge R470, PowerEdge R540, PowerEdge R550, PowerEdge R570, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R670, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R770, PowerEdge R7715, PowerEdge R7725, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
Article Properties
Article Number: 000194588
Article Type: Solution
Last Modified: 07 May 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.