PowerEdge:Windows - 系统启动至“应用更新作C0190019出错”
Summary: 本文提供了解决 Windows 中特定无法启动情况的步骤:“应用更新作 x of y(文件名)C0190019出错”
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Windows 无法启动,并且卡在显示 Windows 徽标的屏幕上,并显示消息“应用更新作 x of y (文件名)C0190019出错”。x 和 y 表示的数字不同,文件名也不同。
Cause
已知两个可能的原因:
- C: 驱动器已满或几乎已满。
- 更新 Windows 的过程中出现问题。
Resolution
出现此问题时,Windows 无法启动。启动至安全模式时,将生成相同的错误屏幕。Windows Recovery Environment (WinRE) 是进行故障处理的唯一可行选项。
可以通过启动至作系统介质来访问 WinRE。如果没有介质可用,系统也会在多次启动失败后自动启动至 WinRE。
系统启动至 WinRE 后,执行以下步骤:
- 在 选择一个选项 菜单中,选择 疑难解答。
- 在 高级选项 菜单中,选择 命令提示符。
- 如果出现提示,请提供管理凭据。
- 在提示符处,键入
diskpart。 - 在
Diskpart提示符,键入list vol确定安装 Windows 的卷的驱动器号。在 WinRE 中,它可能是也可能不是 C:。 - 键入
exit关闭Diskpart。 - 切换到在步骤 5 中获取的驱动器。
- 键入
dir并检查输出底部列出的可用空间量。 - 如果命令的输出指示可用空间不足,请确定哪些文件可以删除或移动到另一个驱动器。释放空间后,重新启动服务器。如果错误仍然存在,请重复步骤 1-7,然后再继续。
- 运行以下命令以撤消任何挂起的 Windows 更新,并将 X:替换为在步骤 5 中获得的驱动器盘符:(此命令可能需要几分钟才能完成。)
dism /image:X:\ /cleanup-image /revertpendingactions
- 命令完成后,运行此命令以检查组件存储中是否存在损坏,再次将 X:替换为步骤 5 中的驱动器盘符:(此命令也需要一段时间才能完成。)
dism /image:X:\ /cleanup-image /scanhealth
- 如果上一个命令指示组件存储中存在损坏,请运行此命令以尝试修复它,再次将 X:替换为步骤 5 中的驱动器盘符:(同样,此命令需要一段时间。如果上一个命令未发现损坏,请跳过此步骤。)
dism /image:X:\ /cleanup-image /restorehealth
- 键入 exit 以关闭命令提示符并返回 到“选择一个选项 ”菜单。
- 单击 关闭 PC。
- 系统关闭后,重新开机。它可能会运行自动启动修复,但随后应启动至 Windows。
Affected Products
Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022, Microsoft Windows Server 2025, Poweredge C4140, PowerEdge C6420, PowerEdge C6520, PowerEdge C6525, PowerEdge C6615, PowerEdge C6620, PowerEdge FC640
, PowerEdge HS5610, PowerEdge HS5620, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge MX740C, PowerEdge MX840C, PowerEdge R260, PowerEdge R360, PowerEdge R470, PowerEdge R540, PowerEdge R550, PowerEdge R570, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R670, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R770, PowerEdge R7715, PowerEdge R7725, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640
...
Article Properties
Article Number: 000194588
Article Type: Solution
Last Modified: 07 May 2025
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.