PowerProtect: PPDM 19.10 - Replication Manager service not running
Summary: The PowerProtect Data Manager [PPDM] 19.10 release has a known issue that can lead to the Replication Manager service not starting. This knowledge base details how to validate and resolve this issue. ...
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Symptoms
PPDM Health dashboard shows an active issue with Components:
After expanding Health information by clicking the View All button, the Replication Manager Component shows it is unavailable (-30 deduction):
This can be verified by navigating to the Gear icon in the top right of the UI, selecting Support, then System Health:

After expanding Health information by clicking the View All button, the Replication Manager Component shows it is unavailable (-30 deduction):
This can be verified by navigating to the Gear icon in the top right of the UI, selecting Support, then System Health:

Cause
PPDM 19.10 contains a code change which introduces additional verification steps for the Replication Manager service, including checking all stages of enabled protection policies.
When an exclusion policy is enabled, these checks will return a null result as exclusion policies have no stages defined and will prevent the Replication Manager service from starting.
When an exclusion policy is enabled, these checks will return a null result as exclusion policies have no stages defined and will prevent the Replication Manager service from starting.
Resolution
- Disable all exclusion policies. This will have no operational impact as the assets already assigned to the exclusion policies services the purpose of excluding them from being consumed by other protection policies.
- Restart the Replication Manager service. This can be done by logging into the PPDM CLI and running the following command:
replmgr restart
Article Properties
Article Number: 000197770
Article Type: Solution
Last Modified: 27 Sep 2022
Version: 3
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