PowerProtect: Data Protection Rapid Upgrade Checker schlägt bei DNS-Prüfung fehl mit dem Fehler "Der für Komponenten festgelegte Hostname ..."

Summary: PowerProtect Data Protection (DP) Rapid Upgrade Checker Tool (RUCK) schlägt bei DNS-Prüfung (Domain Name System) fehl – Fehler: "[FEHLER] Die Hostnamen, die für die Komponenten xxx auf ihren jeweiligen VMs festgelegt wurden, unterscheiden sich von denen, die vom DNS aufgelöst wurden. Stellen Sie sicher, dass die Hostnamen für alle Komponenten korrekt festgelegt sind, und versuchen Sie es erneut." ...

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Symptoms

Das RUCK-Tool schlägt bei DNS Check mit dem folgenden Fehler fehl:

[ERROR] The hostname set for components xxx on their respective VMs are different than the ones resolved from the DNS. Ensure that the hostnames are set correctly for all components and try again.

Cause

Dieser Fehler kann auftreten, wenn der Hostname der Komponente in DNS nicht mit den festgelegten Hostnamen auf den Komponenten übereinstimmt. Eine mögliche Ursache sind Änderungen am DNS nach der Bereitstellung.

Resolution

HINWEIS: Das RUCK-Tool ruft die DNS-Server aus der Datei ab /usr/local/dataprotection/var/configmgr/server_data/config/commonconfig.xml. Die primären und sekundären DNS-Server, die in der commonconfig.xml erwähnt werden, sind diejenigen, die das RUCK-Tool verwendet, um Suchvorgänge für alle Komponenten der Integrated Data Protection Appliance auszuführen. Nutzer müssen sicherstellen, dass die korrekten DNS-Server-IP-Adressen in der commonconfig.xml Datei aufgeführt sind.
 
HINWEIS: Das GoIDPA-Tool kann weitere Informationen zu diesem Problem bereitstellen. Folgen Sie dem folgenden Artikel, um GoIDPA zu installieren:
Führen Sie dann den folgenden Befehl auf dem ACM aus:
./goidpa appliance hostname


Wenn die hostname check failure Bei einigen Komponenten wird ein Problem festgestellt. Befolgen Sie dann die folgenden Schritte für die fehlerhaften Komponenten:

  1. Verwenden Sie den folgenden Befehl in ACM, um zu überprüfen, ob der DNS die Komponenten-IP in die richtige Domain auflöst:
host -W 10 -T <component IP> <DNS IP>

<Note: DNS can be found in /etc/resolv.conf>
  1. Verwenden Sie den folgenden Befehl für die jeweilige Komponente, um den Hostnamen abzurufen:
hostname -f (for all components except Protection Storage/Data Domain and Hypervisor Manager/vCenter)
hostname.get (for Hypervisor Manager/vCenter)
hostname (for Protection Storage/Data Domain)
  1. Vergleichen Sie die beiden Hostnamen. Es muss identisch sein. Falls nicht, korrigieren Sie den Hostnameneintrag auf dem entsprechenden DNS-Server und fahren Sie fort.
HINWEIS: Wenn die Hostnamen identisch sind, aber ein Unterschied zwischen dem Hostnameneintrag im DNS und dem auf der Komponente festgelegten Hostnamen besteht, wenden Sie sich an den technischen Support von Dell und geben Sie diese Artikel-ID an.

Affected Products

PowerProtect Data Protection Software, Integrated Data Protection Appliance Family, Integrated Data Protection Appliance Software

Products

PowerProtect DP4400, PowerProtect DP5300, PowerProtect DP5800, PowerProtect DP8300, PowerProtect DP8800, PowerProtect DP5900, PowerProtect DP8400, PowerProtect DP8900
Article Properties
Article Number: 000197833
Article Type: Solution
Last Modified: 09 Jul 2025
Version:  13
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