PowerProtect: Rask oppgraderingskontroll for databeskyttelse mislykkes i DNS-kontroll med feilmeldingen «Vertsnavnet er angitt for komponenter...»

Summary: PowerProtect Data Protection (DP) Rapid Upgrade Checker-verktøyet (RUCK) mislykkes på Domain Name System (DNS) Sjekk med feil: "[ERROR] Vertsnavnet som er angitt for komponenter xxx på deres respektive virtuelle maskiner, er forskjellige fra de som er løst fra DNS. Kontroller at vertsnavnene er riktig angitt for alle komponenter, og prøv på nytt." ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

RUCK-verktøyet mislykkes på DNS Sjekk med følgende feil:

[ERROR] The hostname set for components xxx on their respective VMs are different than the ones resolved from the DNS. Ensure that the hostnames are set correctly for all components and try again.

Cause

Denne feilen kan oppstå hvis komponentens vertsnavn i DNS ikke samsvarer med de angitte vertsnavnene på komponentene. En mulig årsak er endringer på DNS etter distribusjon.

Resolution

MERK: RUCK-verktøyet henter DNS-serverne fra filen /usr/local/dataprotection/var/configmgr/server_data/config/commonconfig.xml. De primære og sekundære DNS-serverne som nevnes i commonconfig.xml, er de som RUCK-verktøyet bruker til å kjøre oppslag for alle Integrated Data Protection Appliance-komponenter. Brukere må sørge for at riktige DNS-server-IP-adresser er nevnt i commonconfig.xml-filen.
 
MERK: GoIDPA-verktøyet kan gi mer informasjon om dette problemet, følg artikkelen nedenfor for å installere GoIDPA:
Kjør deretter følgende kommando på ACM:
./goidpa appliance hostname


Hvis hostname check failure Det er observert et problem for en komponent, og følg deretter trinnene nedenfor for komponenter med feil:

  1. Bruk kommandoen nedenfor på ACM for å kontrollere om DNS løser komponent-IP til riktig domene:
host -W 10 -T <component IP> <DNS IP>

<Note: DNS can be found in /etc/resolv.conf>
  1. Bruk følgende kommando på den respektive komponenten for å få vertsnavnet:
hostname -f (for all components except Protection Storage/Data Domain and Hypervisor Manager/vCenter)
hostname.get (for Hypervisor Manager/vCenter)
hostname (for Protection Storage/Data Domain)
  1. Sammenlign de to vertsnavnene. Det må være det samme. Hvis ikke, korriger vertsnavnoppføringen på den respektive DNS-serveren og gå videre.
MERK: Hvis vertsnavnene er de samme, men det er forskjell mellom vertsnavn-oppføringen på DNS og vertsnavnet som er angitt på komponenten, kan du kontakte Dells tekniske kundestøtte og nevne denne artikkel-ID-en.

Affected Products

PowerProtect Data Protection Software, Integrated Data Protection Appliance Family, Integrated Data Protection Appliance Software

Products

PowerProtect DP4400, PowerProtect DP5300, PowerProtect DP5800, PowerProtect DP8300, PowerProtect DP8800, PowerProtect DP5900, PowerProtect DP8400, PowerProtect DP8900
Article Properties
Article Number: 000197833
Article Type: Solution
Last Modified: 09 Jul 2025
Version:  13
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.