ECS: 3.7: S3: StorageClass field missing in xml response when listing buckets
Summary: In ECS 3.7 field is missing in the xml response when listing buckets
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Applications fail to read the <StorageClass> when listing a bucket.
The field is missing in the return.
The field is missing in the return.
Cause
Applications checking for <StorageClass> wont be able to proceed as the field is missing in the xml file returned by the ECS.
At this point Storage Class is not used in ECS and always should returns "Standard".
Example Response in 3.7:
At this point Storage Class is not used in ECS and always should returns "Standard".
<StorageClass>STANDARD</StorageClass>
<StorageClass>STANDARD</StorageClass>
However, some applications may depend on return of this value.
Example Response in 3.7:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<ListBucketResult xmlns="http://s3.amazonaws.com/doc/2006-03-01/">
<Name>mike-s3</Name>
<Prefix/>
<Marker/>
<MaxKeys>1000</MaxKeys>
<IsTruncated>false</IsTruncated>
<ServerSideEncryptionEnabled>false</ServerSideEncryptionEnabled>
<Contents>
<Key>20220308_231130_run_Health_Check.zip</Key>
<LastModified>2022-03-09T18:24:39.604Z</LastModified>
<ETag>"35f6f6e4fdb993e792b4865249ecc0c8"</ETag>
<Size>96662</Size>
<Owner>
<ID>mike</ID>
<DisplayName>mike</DisplayName>
</Owner>
<IsFanoutObject>false</IsFanoutObject>
</Contents>
</ListBucketResult>
Resolution
The issue will be fixed in 3.7.0.2
As a temporary workaround the application can list the bucket using the "?versions" tag on the list command:
Example:
As a temporary workaround the application can list the bucket using the "?versions" tag on the list command:
Example:
sudo perl ./s3curl.pl --id xxx -- -v "http://10.x.x.x:9020/mike-s3?versions"| xmllint --format -
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<ListVersionsResult xmlns="http://s3.amazonaws.com/doc/2006-03-01/">
<Name>mike-s3</Name>
<Prefix/>
<KeyMarker/>
<VersionIdMarker/>
<MaxKeys>1000</MaxKeys>
<IsTruncated>false</IsTruncated>
<Version>
<Key>20220308_231130_run_Health_Check.zip</Key>
<VersionId>null</VersionId>
<IsLatest>true</IsLatest>
<LastModified>2022-03-09T18:24:39.604Z</LastModified>
<ETag>"35f6f6e4fdb993e792b4865249ecc0c8"</ETag>
<Size>96662</Size>
<Owner>
<ID>mike</ID>
<DisplayName>mike</DisplayName>
</Owner>
<StorageClass>STANDARD</StorageClass>
</Version>
</ListVersionsResult>
Affected Products
ECS, ECS Appliance, ECS Appliance Gen 2, ECS Appliance Gen 3, ECS Appliance Hardware Gen3 EX300, ECS Appliance Hardware Gen3 EX3000, ECS Appliance Hardware SeriesArticle Properties
Article Number: 000198731
Article Type: Solution
Last Modified: 19 Dec 2022
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.