NetWorker: VM File Level Recovery Mount Operation Fails with "Error from Data Domain: 'Invalid Username or Password"

Summary: A Virtual Machine (VM) File Level Recovery (FLR) is being performed through NetWorker, using the NetWorker VMwar Protection (NVP) vProxy appliance. During the FLR, the mount process fails. The error returned is that the nsrvproxy_flr process failed to log in to the Data Domain. ...

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Symptoms

The following error appears during an FLR mount attempt:

nsrvproxy_flr: vProxy Log: YYYY-MM-DDTHH:mm:SS Z INFO: [@(#) Build number: 38] Creating datastore
nsrvproxy_flr: vProxy Log: YYYY-MM-DDTHH:mm:SS Z NOTICE: [@(#) Build number: 38] DD Host = 'DATA_DOMAIN_ADDRESS', DD Model = 'DD_MODEL', DDOS Version = 'Data Domain OS #.#.#.#', DDBoost Version = '#.#.#.#'
nsrvproxy_flr: vProxy Log: YYYY-MM-DDTHH:mm:SS Z ERROR: [@(#) Build number: 38] Error from DataDomain: '**** Invalid user name or password., code 5094'
nsrvproxy_flr: vProxy Log: YYYY-MM-DDTHH:mm:SS Z ERROR: [@(#) Build number: 38] A 'POST' method to DataDomain at 'https://DATA_DOMAIN_ADDRESS:3009/rest/v1.0/auth' responded with code 401.
nsrvproxy_flr: vProxy Log: YYYY-MM-DDTHH:mm:SS Z ERROR: [@(#) Build number: 38] Failed to login to DataDomain service at 'https://DATA_DOMAIN_ADDRESS:3009/rest/v1.0/auth'  
NOTE: This same symptom is observed when performing an Instant Recover. Other VM recovery types and backup operations complete without issue.

Cause

The Management host details are not accurate in the Data Domain resource of NetWorker.

Resolution

Update the Management user credentials for the Data Domain in NetWorker:


1. Log in to the NetWorker Management Console (NMC) as an administrator of the NetWorker server.
NOTE: If you lack access to the default NetWorker admin account, use another NetWorker user or external user account with 'Application Administrator' rights. 
2. From the NMC Enterprise screen, connect to the NetWorker server performing the restore.
3. Click the Devices button on the taskbar.
4. In the expanded left navigation pane, select Data Domain Systems.
5. In the right details pane, right-click the Data Domain system and select properties.
6. In the NSR Data Domain Properties window access section, enter the Management user, and Management password. 
NOTE: The Management user should be having DD admin privileges. This can be confirmed from the Data Domain Web Management user interface. The default admin account is sysadmin. Validate that you can log in to the DD Web interface with the account.


DD Management User and password

           7. Select OK to save the changes.
8. Perform the FLR again.

Additional Information

The Data Domain web interface shows what user role that a system user has:

  1. Go to https://DATA_DOMAIN_ADDRESS/ddem/
  2. Log in with an Administrative user, for example sysadmin
  3. Go to Administration->Access->Local Users
  4. Validate that the management user specified in NetWorker, has admin management role and is enabled:
DDEM example

This can also be verified from a sysadmin prompt on the DD:

user show list
Example:
sysadmin@ddve01# user show list
User list from node "localhost".
Name                         Uid   Role    Last Login From        Last Login Time            Status    Disable Date
--------------------------   ---   -----   --------------------   ------------------------   -------   ------------
sysadmin                     100   admin   192.168.9.100          Mon Mar 24 14:15:37 2025   enabled   never

Affected Products

NetWorker Family
Article Properties
Article Number: 000198764
Article Type: Solution
Last Modified: 25 Mar 2025
Version:  4
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