Dell Repository Manager: La versione 3.4 potrebbe non riuscire a caricare la pagina Preferenze dopo l'aggiornamento.

Summary: Dell Repository Manager (DRM) 3.4 potrebbe arrestarsi quando viene visualizzata la schermata della rotella che gira per la pagina delle preferenze negli scenari di aggiornamento.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

È stato osservato un problema che si verificava quando l'utente aveva modificato il percorso di archiviazione dalla cartella predefinita a un'altra cartella prima dell'aggiornamento di DRM 3.x alla versione 3.4.
Questo articolo si applica ai sistemi operativi Windows.


Caricamento DRM in corso 

I registri DRM possono avere le seguenti tracce:

SEVE com.dell.sm.downloader.DSMLocation check                                    null  java.nio.file.FileAlreadyExistsException
INFO com.dell.drm.service.InitialConfiguration intialize                         Store preference settings is inaccessible using default store
SEVE com.sun.jersey.spi.container.ContainerResponse mapMappableContainerException The RuntimeException could not be mapped to a response, re-throwing to the HTTP container
java.lang.NullPointerException

Cause

Il servizio DRM 3.4 viene eseguito con privilegi utente diversi Local_service rispetto alle precedenti versioni DRM 3.x. Gli archivi personalizzati (cartelle) menzionati in DRM potrebbero non avere accesso a Local_service utente con conseguente errore.
 

Resolution

Aggiungi Local_Service cartella dall'utente al cliente menzionata in DRM come store. Assicurarsi che l'utente disponga di read/write Autorizzazioni.
Dopo aver aggiunto l'utente e le autorizzazioni, riavviare il servizio DRM per risolvere il problema.

 

Affected Products

Poweredge C4140, PowerEdge C6400, PowerEdge C6420, PowerEdge C6520, PowerEdge C6525, PowerEdge C6600, PowerEdge C6615, PowerEdge C6620, PowerEdge FC640, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge M7701, PowerEdge M7725, PowerEdge MX5016s , PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c, PowerEdge MX840C, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440, PowerEdge R450, PowerEdge R470, PowerEdge R540, PowerEdge R550, PowerEdge R570, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R670, PowerEdge R6715, PowerEdge R6725, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R770, PowerEdge R770AP, PowerEdge R7715, PowerEdge R7725, PowerEdge R7725xd, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T40, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640, Dell EMC Repository Manager - Current Versions ...
Article Properties
Article Number: 000198871
Article Type: Solution
Last Modified: 01 Sep 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.