Avamar: SQL-Multistream-Backup und -Wiederherstellung können mit der Meldung "Die API wartete und das Timeout-Intervall war abgelaufen" fehlschlagen.
Summary: SQL-Multistreaming-Backup und -Wiederherstellung schlagen möglicherweise mit der Meldung "Die API wartet und das Timeout-Intervall war abgelaufen" fehl, was sich auf SQL 2017 und 2019 auf großen Datenbanken auswirkt. ...
Symptoms
SQL-Multistream-Backup und -Wiederherstellung können mit folgenden Fehlern fehlschlagen:
2021-09-16 15:01:54 avsql Error <6478>: VDS::Getconfig failed with 'The api was waiting and the timeout interval had elapsed' 2021-09-16 15:01:54 avsql Error <6478>: VDS::Getconfig failed with 'The api was waiting and the timeout interval had elapsed' 2021-09-16 15:01:54 avsql Error <6478>: VDS::Getconfig failed with 'The api was waiting and the timeout interval had elapsed' 2021-09-16 15:01:54 avsql Error <6479>: Timed out. Was Microsoft SQLServer running?
Alle erzeugten avtar-Threads für "avsql stack execution" würden keine Fortschrittsbytes anzeigen.
Dieses Problem tritt auf, wenn sechs oder mehr Streams für große Datenbanken mit einer Größe von etwa einem Tera Byte oder mehr festgelegt sind.
Dieses Problem betrifft Microsoft SQL 2017- und 2019-Umgebungen.
Das Ausführen desselben Backups in einem einzigen Stream wäre abgeschlossen, würde jedoch viel Zeit in Anspruch nehmen.
Cause
Es wurde festgestellt, dass sich das VDI-Verhalten für die Microsoft SQL-Versionen 2017 und 2019 von der vorherigen Microsoft SQL-Version 2016 unterscheidet.
Im Wesentlichen wird für SQL 2016 der Parameter "SetEvent" verwendet, wenn die Backup-Konfiguration abgeschlossen ist, während für neuere SQL-Versionen stattdessen ein "Semaphore count" verwendet wird.
Diese Microsoft VDI-Änderung wirkte sich auf die Avamar-Komponente "avsql" aus, wenn Multi-Streaming für Avamar-Backups und -Wiederherstellungen aktiviert war, was zu dem oben beschriebenen Fehler führte.
Um dieses Problem zu beheben, hat das Avamar Engineering-Team den SQL-Plug-in-Code in "avsql" geändert und das Deadlock-Szenario behoben.
Resolution
Um dieses Problem zu beheben, führen Sie ein Upgrade des Backup-Clients und des SQL-Plug-ins auf Version 19.8 oder höher durch, auf die die Codekorrektur bereits angewendet wurde.
Darüber hinaus wird empfohlen, die neueste kumulative HF des SQL-Plug-ins (basierend auf den Versionen) anzuwenden, die andere Codekorrekturen enthält:
-
- Für 19,8 => HF 338744
- Für 19,9 => HF 338778
Informationen zum Herunterladen des Hotfix finden Sie im Abschnitt "Suchen nach einem Hotfix mit seiner Nummer" im Artikel Avamar: Anleitung zum Suchen und Herunterladen eines Produkt-Hotfix-, Patch-, Installations- oder Upgradepakets von der Dell Supportwebsite