Avamar: El respaldo y la restauración multistreaming de SQL pueden fallar con el mensaje "La API estaba esperando y el intervalo de tiempo de espera agotado había transcurrido"
Summary: El respaldo y la restauración multistreaming de SQL pueden fallar con el mensaje "La API estaba esperando y el intervalo de tiempo de espera agotado había transcurrido", lo que afecta a SQL 2017 y 2019 en bases de datos grandes. ...
Symptoms
El respaldo y la restauración multistreaming de SQL pueden fallar con:
2021-09-16 15:01:54 avsql Error <6478>: VDS::Getconfig failed with 'The api was waiting and the timeout interval had elapsed' 2021-09-16 15:01:54 avsql Error <6478>: VDS::Getconfig failed with 'The api was waiting and the timeout interval had elapsed' 2021-09-16 15:01:54 avsql Error <6478>: VDS::Getconfig failed with 'The api was waiting and the timeout interval had elapsed' 2021-09-16 15:01:54 avsql Error <6479>: Timed out. Was Microsoft SQLServer running?
Todos los subprocesos avtar generados para la "ejecución de la pila avsql" no mostrarán bytes de progreso.
Este problema ocurre cuando se configuran seis o más flujos para bases de datos grandes de alrededor de uno o más terabytes de tamaño.
Este problema afecta a los entornos de Microsoft SQL 2017 y 2019.
La ejecución del mismo respaldo en un solo flujo se completaría, pero tardaría mucho tiempo.
Cause
Se descubrió que para las versiones 2017 y 2019 de Microsoft SQL, el comportamiento de VDI difiere de la versión anterior de Microsoft SQL 2016.
Esencialmente, para SQL 2016, el parámetro "SetEvent" se utiliza cuando se completa la configuración de respaldo, mientras que para las versiones más recientes de SQL se utiliza un "recuento de semáforos" en su lugar.
Este cambio de Microsoft VDI afectaba al componente "avsql" de Avamar cuando se habilitaba el streaming múltiple para respaldos y restauraciones de Avamar, lo que causaba la falla descrita anteriormente.
Para resolver este problema, el equipo de ingeniería de Avamar cambió el código del plug-in de SQL en "avsql" y abordó el escenario de interbloqueo.
Resolution
Para resolver este problema, actualice el cliente de respaldo y el plug-in de SQL a la versión 19.8 o superior en la que ya se aplicó la corrección de código.
Además, también se recomienda aplicar el HF acumulativo del plug-in de SQL más reciente (basado en las versiones) que incluye otras correcciones de código:
-
- Para 19,8 => HF 338744
- Para 19,9 => HF 338778
Para descargar la revisión, consulte la sección "Buscando una revisión con su número" en el artículo Avamar: Cómo encontrar y descargar un paquete de revisiones, parches, instalación o actualización de un producto desde el sitio web de soporte de Dell