Avamar: Il backup e il ripristino multi-streaming SQL potrebbero non riuscire con il messaggio "L'API era in attesa e l'intervallo di timeout era trascorso"
Summary: Il backup e il ripristino multi-streaming di SQL potrebbero avere esito negativo con il messaggio "L'API era in attesa e l'intervallo di timeout era trascorso" e ciò influisce su SQL 2017 e 2019 su database di grandi dimensioni. ...
Symptoms
Il backup e il ripristino multi-streaming SQL potrebbero avere esito negativo con:
2021-09-16 15:01:54 avsql Error <6478>: VDS::Getconfig failed with 'The api was waiting and the timeout interval had elapsed' 2021-09-16 15:01:54 avsql Error <6478>: VDS::Getconfig failed with 'The api was waiting and the timeout interval had elapsed' 2021-09-16 15:01:54 avsql Error <6478>: VDS::Getconfig failed with 'The api was waiting and the timeout interval had elapsed' 2021-09-16 15:01:54 avsql Error <6479>: Timed out. Was Microsoft SQLServer running?
Tutti i thread avtar generati per "avsql stack execution" non mostrerebbero alcun byte di avanzamento.
Questo problema si verifica quando sono impostati sei o più flussi per database di grandi dimensioni di circa uno o più terabyte.
Questo problema riguarda gli ambienti Microsoft SQL 2017 e 2019.
L'esecuzione dello stesso backup in un singolo flusso verrebbe completata, ma richiederebbe molto tempo.
Cause
È stato riscontrato che per Microsoft SQL versioni 2017 e 2019, il comportamento VDI differisce dalla precedente versione 2016 di Microsoft SQL.
In sostanza, per SQL 2016 viene utilizzato il parametro "SetEvent" al termine della configurazione di backup, mentre per le versioni più recenti di SQL viene utilizzato un "conteggio dei semafori".
Questa modifica della VDI Microsoft ha interessato il componente "avsql" di Avamar quando il multi-streaming era abilitato per i backup e i ripristini Avamar, causando l'errore descritto in precedenza.
Per risolvere questo problema, il team di progettazione di Avamar ha modificato il codice del plug-in SQL in "avsql" e ha risolto lo scenario di stallo.
Resolution
Per risolvere questo problema, aggiornare il backup client e il plug-in SQL alla versione 19.8 o successiva in cui è già applicata la correzione del codice.
Inoltre, si consiglia anche di applicare l'HF cumulativo del plug-in SQL più recente (in base alle versioni) che include altre correzioni del codice:
-
- Per 19,8 => HF 338744
- Per 19,9 => HF 338778
Per scaricare l'hotfix, vedere la sezione "Ricerca di un hotfix con il relativo numero" nell'articolo Avamar: Come trovare e scaricare un hotfix, una patch, un pacchetto di installazione o aggiornamento di un prodotto dal sito web di supporto Dell