VxRail: vCenter 7.0.3 build 19234570 | Skyline health is not available from both UI and CLI
Summary: vSAN Skyline health fails to load any data on RETEST. There is no error in the UI.
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Symptoms
vSAN Skyline health fails to load any data on RETEST. There is no error in the UI.
vmware-vsan-health-service.log:
vmware-vsan-health-service.log:
2022-06-09T09:22:19.292+08:00 ERROR vsan-mgmt[49569] [VsanVcClusterHealthSystemImpl::queryClusterHealthSummaryInThread opID=noOpId] Fail to query cluster health summary year 10000 is out of range Traceback (most recent call last): File "bora/vsan/health/vpxd/pyMoVsan/VsanVcClusterHealthSystemImpl.py", line 3379, in queryClusterHealthSummaryInThread File "bora/vsan/health/vpxd/pyMoVsan/VsanVcClusterHealthSystemImpl.py", line 3987, in _doQueryClusterHealthSummary File "bora/vsan/health/vpxd/pyMoVsan/VsanVcClusterHealthSystemImpl.py", line 8831, in _generateHealthGroupResult File "bora/vsan/health/vpxd/pyMoVsan/VsanHealthHelpers.py", line 3277, in wrapper File "bora/vsan/health/vpxd/pyMoVsan/VsanVcClusterHealthSystemImpl.py", line 9105, in _generateEncryptionGroupResult File "bora/vsan/health/vpxd/pyMoVsan/VsanVcClusterHealthSystemImpl.py", line 10567, in _GetKmsConnectionTest ValueError: year 10000 is out of rangeRunning the command on vCenter does not show +0000 (that is, not in UTC)
date +"%Z %z"
Cause
It is caused by the time zone being configured in vCenter as something other than UTC.
This is a known issue, and the fix will be available in a future release of vCenter [Post: vCenter 7.0.3 build 19234570}
This is a known issue, and the fix will be available in a future release of vCenter [Post: vCenter 7.0.3 build 19234570}
Resolution
To resolve this issue:
- Log in to the vCenter VAMI page and change the timestamp to UTC.
- Restart the vSAN health service.
vmon-cli -r vsan-health
Article Properties
Article Number: 000201162
Article Type: Solution
Last Modified: 11 Sep 2025
Version: 5
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