PowerStore X: VM is inaccessible after the VMFS resize and host reboot

Summary: The KB Article is for the issue when a PowerStore X VM is inaccessible after VMFS resize and host reboot.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The symptoms are that the Linux network devices are down inside the VM, resulting in no Management or Storage access to the VM. From the vCenter perspective this looks as follows:
image.png

Cause

The ESXi upgrade from 6.7 to 7.0 requires a smaller local VMFS datastore to give ESXi 7.0 more space for its operating system. The datastore is resized prior to the ESXi upgrade. The resize procedure backs up the existing local datastore and then destroys it. A smaller datastore is created and the backed up files are restored to it. The resize procedure automatically stages the ESXi upgrade so that the next boot will be to ESXi 7.0. The first time the ESXi host boots 7.0, it sees the cached network configuration data (.dvsData) in the new datastore but then replaces it with the path to the datastore that was destroyed by the resize procedure. All subsequent writes use this incorrect location and fail. The missing switch configuration data will not prevent the PowerStore VM from starting but may result in the network adapters that are associated with the Distributed Switch in the VM's configuration to be in a disconnected state after the VM is powered on.

Resolution

To fix the issue, the following steps need to be done:

  1. Ensure that the PowerStore X VM is powered on. Power it on if needed with vCenter → Datacenter → Cluster → VM → Power → Power On.
  2. Open the PowerStore X VM settings via vCenter → Datacenter → Cluster → VM → Summary → Edit Settings.
  3. Choose the unconnected network adapters and modify their portgroups to be PG_Internal and press OK.

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 4. Modify the network adapter portgroups to the original values according to the table below and press OK.

image.png
 

Affected Products

PowerStore 1000X, PowerStore 3000X, PowerStore 5000X, PowerStore 7000X, PowerStore 9000X

Products

PowerStore
Article Properties
Article Number: 000201420
Article Type: Solution
Last Modified: 13 Jun 2025
Version:  3
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