PowerStore: CommVault backup not working since upgrade to PowerStoreOS V3
Summary: CommVault backup not working since upgrade to PowerStoreOS V3
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
After an upgrade to PowerStoreoS version 3.0.x.x, backups stopped working as expected.
CommVault backup works on PowerStoreOS V 2.x.x.x.
CommVault backup works on PowerStoreOS V 2.x.x.x.
Cause
The appliance serial number was never published for public use on PowerStore.
An application could get the serial number before PowerStoreOS V3 because the strict use of the Dell service tag was not enforced.
As of PowerStoreOS V3, it is enforced, so the use of the serial number no longer works.
An application could get the serial number before PowerStoreOS V3 because the strict use of the Dell service tag was not enforced.
As of PowerStoreOS V3, it is enforced, so the use of the serial number no longer works.
Resolution
Commvault must be updated to a new version that supports the use of the PowerStore appliance Dell service tag instead of the serial number.
Additional Information
Possible errors observed:
Failure Reason: Failed to prepare snapshot. : [Failed to get array details using [appliance].
Errors returned by storage array [The REST property [appliance.serial_number] cannot be found. ].]
vCentre reports "failed to get array details using appliance."
Failure Reason: Failed to prepare snapshot. : [Failed to get array details using [appliance].
Errors returned by storage array [The REST property [appliance.serial_number] cannot be found. ].]
vCentre reports "failed to get array details using appliance."
.. 10/23 19:00:57 .. Scheduler Set pending cause [Failed to prepare snapshot. : [Failed to get array details using [appliance].
.. 10/23 19:01:01 .. Scheduler Ignored pending cause [Failed to create hardware snapshot. Please check vsbkp and cvma logs for more details.]::Client [xxxxx] Application [xxxxx] Message Id [1526726704] RCID [0] Reservation Id [0]. Level [0] flags [0] id [0] overwrite [0] append [0] CustId[0].
Affected Products
PowerStoreArticle Properties
Article Number: 000201985
Article Type: Solution
Last Modified: 24 Nov 2022
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.