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Connectrix SANnav: Telemetry registration failed, the chassis is already bound with another server

Summary: Telemetry registration failed due to the switches could only bind to one SANnav server for telemetry.

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Symptoms

After discovering the fabrics, SANnav reports "Telemetry registration failed. Binding SANnav server with chassis <switch name> (<switch IP address>) failed. The chassis is already bound with another server (<IP address>)."

Cause

That IP address belongs to another SANnav server.
The FC switches could only bind to one SANnav server for telemetry.

Resolution

If the switches are managed by two SANnav servers simultaneously, ignore the error message on the second SANnav.

If the old SANnav will be decommissioned but it is still accessible, stop monitoring the fabrics on both SANnav servers, wait for 5 minutes, and then start monitoring on the new SANnav server.

If the old SANnav has already been decommissioned (not functioning), follow the below steps to unbind it and then register to the new one:
  1. Stop monitoring the fabrics on the new SANnav server where the error is reported.
  2. On the switches, run the comand `mgmtapp --unbind`. It should return "Application unbind success".
  3. Wait for two minutes, and monitor the fabrics in SANnav.
  4. (Optional if you have root access.) Wait for five minutes, run `telemetryapp --show all` (with root account) on the switches. If the registration is fine, it shall show the new SANnav IP address.
  5. Wait for 15 minutes, and check if the error message has stopped in the new SANnav.

Affected Products

Connectrix SANnav
Article Properties
Article Number: 000202206
Article Type: Solution
Last Modified: 06 Nov 2022
Version:  2
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