Connectrix:サンナビ: San Navアプリケーションでフローを作成した後、データが見つかりません

Summary: この問題は、ユーザがDan Navアプリケーションでフロー制御を設定しようとしたときに、[Inventory -->Flows]タブにデータが入力されていない場合に発生します。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

以下は、フロー制御の作成時に表示されるエラーです。
フローエラー

 

Cause

この問題は、次の場合に発生します。

  • San Navでフロー制御を設定するための前提条件が満たされていません。
  • スイッチCLIでフロー機能が有効になっていない場合

 

Resolution

1.フロー制御機能を開始する前に、次の前提条件が満たされていることを確認してください。

  • スイッチとSANnav間のレイテンシーが100ミリ秒以下であることを確認します。スイッチとSANnavの両方を同じデータセンターに配置することを推奨します。
  • すべてのファブリックID (FID)が単一(または同じ)サーバーで検出され、すべてのFIDが認証および管理されていることを確認します。
  • SANnavをインストールする前に、Network Time Protocol (NTP)が設定されていることを確認します。
  • スイッチからサーバーにテレメトリー データが送信されていることを確認します。
  • スイッチとSANnavサーバーのクロックが同期していることを確認します。NTPを使用したクロック同期は、すべてのスイッチとSANnavアプリケーション サーバーに必須です。クロックが同期していないと、フローとその統計情報が失われる可能性があります。SANnavサーバーとスイッチが同期されていない場合は、アプリケーション イベント メッセージによってアラートが表示されます。

クロックは、次の 2 つの方法で同期できます。

  1. tsclockserver「<IPV4>;<IPV6>;<DNS name>」コマンドを実行します。

    • このコマンドを発行すると、ファブリック内のすべてのスイッチに詳細が配信されます。
    • Create New Configurationダイアログに次のコードを入力して、SANnav構成管理機能を使用してスイッチの時刻をNTPサーバーに同期します。このアクションにより、SANnavに構成ポリシーが作成され、スイッチにプッシュされます。
      {
       "BasicConfigurations":{
       "NTP_TimeServer":[
       {
       "ipAddress": "10.10.10.10"
       }
       ]
       }
      }
  2. SANnavサーバーとNTPサーバーのクロックは、次のように同期できます。

    • Red Hat Linuxの場合は、SANnavサーバーでコマンドntpdate NTPserverを発行します。ここで、NTPserverはNTPサーバーのホスト名またはIPアドレスです。
    • CentOSの場合は、/etc/ntp.confファイルを開き、次の行があることを確認してから、サーバーを再起動します。
      "ntp.server.com:NTPserver"
      
      Where NTPserver is the hostname or IP address of the NTP server.

2.スイッチでフロー制御が有効になっているかどうかを確認します。

  1. 次のコマンドで確認します。

    flow –show sys_flow_monitor
  2. 有効になっていない場合は、コマンド フローを使用して有効にします

    –activate sys_flow_monitor

3.この後、フロー制御を作成しようとすると、データが正常に表示されます。

フローの成功

調査モード。
調査モード

 

Additional Information

メモ: 前述の前提条件に従って、フロー制御を作成する前に、スイッチでNTPを構成する必要があります。ただし、構成されていない場合でも、後で構成でき、フローは引き続き機能します。いいえ、San Navアプリケーションをアンインストールして再インストールする必要はありません。

Affected Products

Connectrix SANnav
Article Properties
Article Number: 000204414
Article Type: Solution
Last Modified: 17 Dec 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.