Connectrix: San Nav: Não é possível localizar nenhum dado depois de criar fluxos no aplicativo San Nav

Summary: Esse problema ocorre quando um usuário tenta configurar o aplicativo Flows Control On Dan Nav e não há dados sendo preenchidos na guia Inventory -->Flows.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Veja abaixo o erro observado quando o controle de fluxo é criado:
Erro de fluxo

 

Cause

Esse problema ocorre quando:

  • Os pré-requisitos não foram atendidos para configurar o Controle de Fluxo no San Nav.
  • Quando o recurso de fluxo não está ativado na CLI do switch

 

Resolution

1. Antes de iniciar o recurso de controle de fluxo, certifique-se de que os pré-requisitos abaixo sejam atendidos.

  • Certifique-se de que a latência entre o switch e o SANnav deve ser menor ou igual a 100 ms. A recomendação é colocar o switch e o SANnav no mesmo data center.
  • Certifique-se de que todos os IDs de fabric (FIDs) sejam detectados em um único servidor (ou no mesmo) servidor e que todos os FIDs sejam autenticados e gerenciados.
  • Certifique-se de que o NTP (Network Time Protocol) esteja configurado antes da instalação do SANnav.
  • Certifique-se de que o switch está enviando dados de telemetria para o servidor.
  • Certifique-se de que os relógios do switch e do servidor SANnav estejam sincronizados. A sincronização do relógio usando NTP é obrigatória para todos os switches e o servidor de aplicativos SANnav. Se os relógios não estiverem sincronizados, você poderá perder fluxos e suas estatísticas. Uma mensagem de evento do aplicativo alerta você se o servidor SANnav e o switch não estiverem sincronizados.

Você pode sincronizar os relógios de duas maneiras:

  1. Execute o tsclockserver "<IPV4>;<IPV6>;<DNS name>" no switch principal.

    • A emissão desse comando distribui os detalhes a todos os switches de um fabric.
    • Sincronize a hora do switch com o servidor NTP usando o recurso SANnav Configuration Management digitando o código a seguir na caixa de diálogo Create New Configuration. Essa ação cria uma política de configuração no SANnav e a envia para os switches.
      {
       "BasicConfigurations":{
       "NTP_TimeServer":[
       {
       "ipAddress": "10.10.10.10"
       }
       ]
       }
      }
  2. Você pode sincronizar o servidor SANnav com o relógio do servidor NTP da seguinte maneira:

    • Para Red Hat Linux, execute o comando ntpdate NTPserver no servidor SANnav, em que NTPserver é o nome do host ou endereço IP do servidor NTP.
    • Para o CentOS, abra o arquivo /etc/ntp.conf, verifique se a seguinte linha existe e reinicie o servidor.
      "ntp.server.com:NTPserver"
      
      Where NTPserver is the hostname or IP address of the NTP server.

2. Verifique se o controle de fluxo está ativado no comutador.

  1. Verifique com o comando:

    flow –show sys_flow_monitor
  2. Se ele não estiver habilitado, habilite-o pelo fluxo de comando

    –activate sys_flow_monitor

3. Após isso, tente criar o controle de fluxo e você poderá ver os dados com sucesso:

Sucesso dos fluxos

Modo de investigação.
Modo de investigação

 

Additional Information

Nota: O NTP deve ser configurado nos switches antes da criação do controle de fluxo de acordo com o pré-requisito mencionado. No entanto, se não estiver configurado, ele também poderá ser configurado na parte posterior e os fluxos ainda funcionarão. NÃO é necessário desinstalar e reinstalar o aplicativo San Nav.

Affected Products

Connectrix SANnav
Article Properties
Article Number: 000204414
Article Type: Solution
Last Modified: 17 Dec 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.