Dell Unity: LDAP kullanan çok protokollü bir ortamda, Windows İstemcilerinin Paylaşılan Erişimi, Eşleme Kullanıcı Tarafından Düzeltilemez Olması Nedeniyle Başarısız Oluyor

Summary: Bu makalede, KULLANıLAN şifreleme yönteminin LDAP eşlemeyi etkileyene kadar LDAP kullanırken yanlış eşleme sorunuyla ilgili ayrım ve çözüm adımları açıklanmaktadır.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Unity LDAP doğru şekilde yapılandırılmıştır ancak kullanıcılar eşlenmiş değildir.

LDAP sunucusuna yönelik kullanıcıları aramak için LDAP Arama komutunu kullanıyorsanız doğru şekilde görünürler. 

 
NOT: Arama komutu kök kabuğunda oturum açılmasını gerektirir. Yardıma ihtiyacınız olursa destekle iletişime geçin. Kök kabuğu etkinleştirme ve komutu kullanma konusunda yardımcı olabilir.
 

Komut:

ldapsearch -h <ldapserver ip> -D "<BindDN>" -w <Password> -b "<BaseDN>" -s <scope(base,one,sub)> "cn=<username>"

Başarılı komut örneği:

---------------------
root@solaris11:~# ldapsearch -h 5.6.7.xxx -D "cn=admin,dc=peeps,dc=lab" -w Password123# -b "ou=people,dc=peeps,dc=lab" -s sub "cn=user1"
version: 1
dn: uid=user1,ou=People,dc=peeps,dc=lab
uid: user1
uidNumber: 1
gidNumber: 1
cn: user1
sn: user1
objectClass: top
objectClass: person
objectClass: posixAccount
objectClass: shadowAccount
loginShell: /bin/bash
homeDirectory: /home/user1
You have new mail in /var/mail/root
---------------------


Ancak kullanıcıları aramak için SVC NAS komutu kullanılırsa aşağıdaki mesajla başarısız olur:

Komut:

svc_nas <server name> -ldap -lookup -user <user name>

Başarısız bir komut örneği:

---------------------
service@********* spb:~/user# svc_nas nas_multi -ldap -lookup -user user2

nas_multi : commands processed: 1
command(s) succeeded
output is complete

1659693343: LDAP: 6: LdapService::connect: Connection to Ldap server ***.***.***.*** SUCCEEDED IP[0/1]=***.***.***.*** port=389
1659693343: LDAP: 3: User user2t: User name + password + uid + gid are too large to fit into buffer.
1659693343: LDAP: 6: Unable to get information for user user2
---------------------
---------------------

Ayrıca başarısız olan kullanıcı adı, kullanıcı adı sonrasında gereksiz karakterler de içeriyor olabilir.

Başarılı komut örneği:

---------------------
service@********* spb:~/user# svc_nas nas_multi -ldap -lookup -user user1

nas_multi : commands processed: 1
command(s) succeeded
output is complete

1659694219: LDAP: 6: user: user1, uid: 12333, gid: 12333, homeDir: /home/user1

Command succeeded
---------------------

---------------------

Cause

Müşteri, LDAP şifreleme yöntemini "PBKDF2_SHA256" olarak ayarladi.

Unity "PBKDF2_SHA256" özelliğini destekler ancak bir kısıtlama vardır; [kullanıcı adı + parola + uid + gid] toplamı 452 Bayt dahilinde olmalıdır.

Şifreleme PBKDF2_SHA256 parola için çok sayıda bayt kullanılırsa uidNumber, gidNumber ve uid toplama eklenmiştir. 

452 bayt sınırının aşılması, LDAP çok protokollü bir ortamda eşleme yapılamadığından Windows istemcilerinden paylaşılan erişimin başarısızlanmasına neden olur.

Örneğin, müşteri parolası 447 bayt kullanıyorsa uidNumber, gidNumber ve uid için kullanılacak kalan bayt sayısı yalnızca 5 bayttır.

452 Bayt sınırına uyan örnek:
userPassword= 404 Bayt
uidNumber = 16 Bayt
gidNumber = 16 Bayt
uid = 16 Bayt
Toplam = 452 Bayt

Resolution

SSHA-512 gibi PBKDF2_SHA256 dışındaki bir şifreleme şemasını kullanma seçeneğini değerlendirin.

Unity tarafından desteklenen LDAP Şifreleme Şemaları:
Ağustos 2022'den itibaren aşağıdaki şifreler OE 5.2:
SHA, SHA-256, SHA-384, SHA-512' de mevcuttur. SSHA, SSHA-256, SSHA-384, SSHA-512, MD5, SMD5, PKCS5S2, CRYPT, CRYPT-MD5, CRYPT-SHA-256, CRYPT-SHA-512, PBKDF2_SHA256****
PBKDF2_SHA256 kullanırken [kullanıcı adı + parola + uid + gid] toplamı 452
Bayt ile sınırlıdır.

Affected Products

Dell EMC Unity
Article Properties
Article Number: 000204586
Article Type: Solution
Last Modified: 14 Dec 2023
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.